* Disable JFreeReport for report builder. I have gotten build error. * Use OpenGL. * Use GStreamer 1.x Changelog: New features: see https://wiki.documentfoundation.org/ReleaseNotes/4.4 Summary: == Writer * Master Doument Templates * Shapes can have a TextBox * Improvements to Track Changes * Style dropdown * Line numbering easier to apply for headers and footers * Status bar improvements * Toolbar improvements * Navigator bookmarks * AutoCorrect improvements == Calc * Statistics Wizard (alternative to Excel's Add-in "Analysis ToolPak") * Direct conversion of formulas into static values * Formula engine (AGGREGATE spreadsheet function) * Toolbar improvements * Sheet context menu == Impress and Draw * Text of Master View Object Previews * Select and toggle off master elements directly via Delete * OpenGL transitions * Page Title field * Inherit current style of cells when inserting New row/column in table * Password for editing * Printing: use specified paper size * Zoom Mode button * Toolbar improvements * Menubar improvements == Math * Color support == Core * Included fonts (Caladea and Carlito) * Digitally signed PDF export * Drawing objects * Technical Dictionary == LibreOfficeKit * Impress supports tile rendering == Filters * Many import filters are improved * SharePoint OneDrive connection == GUI * Dialogs conversion to WidgetLayout finished * Sifr as the default icon theme on OS X * Changes to rulers * Start Center * New default templates * New color selector * Reworked paragraph line spacing dropdown * Bullet and Numbering dropdown * Sidebar changes * Context menu changes * Edit / Read-only mode * Tab changes * Firefox Themes * Image scaling * Simplification of Special Character dialog * Icon improvements * Locale in About dialog * UI text improvements == Localization * New languages/locales with locale data (ca-ES-valencia) * Improved language tools (spell-check dictionaries, thesaurus, hyphenation patterns) Bugfixes: https://wiki.documentfoundation.org/Releases/4.4.0/RC1 https://wiki.documentfoundation.org/Releases/4.4.0/RC2 https://wiki.documentfoundation.org/Releases/4.4.0/RC3
15 lines
643 B
Makefile
15 lines
643 B
Makefile
$NetBSD: patch-solenv_gbuild_Module.mk,v 1.3 2015/02/04 18:19:34 ryoon Exp $
|
|
|
|
* Disable never-ending test
|
|
|
|
--- solenv/gbuild/Module.mk.orig 2015-01-22 20:05:28.000000000 +0000
|
|
+++ solenv/gbuild/Module.mk
|
|
@@ -114,7 +114,7 @@ $(call gb_Module_get_target,%) :
|
|
.PHONY : all build build-l10n-only build-non-l10n-only unitcheck slowcheck subsequentcheck perfcheck clean check debugrun help showmodules translations
|
|
.DEFAULT_GOAL := all
|
|
|
|
-all : build $(if $(CROSS_COMPILING),,unitcheck $(if $(gb_PARTIAL_BUILD),,slowcheck))
|
|
+all : build
|
|
|
|
build-tools : $(gb_BUILD_TOOLS)
|
|
$(call gb_Output_announce,loaded tools: $(gb_BUILD_TOOLS),$(true),ALL,6)
|