d14ba10f96
changes: -Rewrite of VDPAU OSD handling -sndio plugin is now buildable -Various bug fixes
26 lines
880 B
Text
26 lines
880 B
Text
$NetBSD: patch-ag,v 1.24 2012/03/21 16:37:15 drochner Exp $
|
|
|
|
--- configure.ac.orig 2012-02-04 00:41:43.000000000 +0000
|
|
+++ configure.ac
|
|
@@ -272,6 +272,10 @@ AC_CHECK_LIB([nsl], [gethostbyname],
|
|
AC_CHECK_LIB([resolv], [hstrerror], [NET_LIBS="-lresolv $NET_LIBS"])
|
|
AC_SUBST(NET_LIBS)
|
|
|
|
+WINE_LIBS=""
|
|
+AC_CHECK_LIB(i386, i386_set_ldt, WINE_LIBS="-li386 $WINE_LIBS",)
|
|
+AC_SUBST(WINE_LIBS)
|
|
+
|
|
AC_CHECK_LIB([rt], [clock_getres],
|
|
[RT_LIBS="-lrt"
|
|
AC_DEFINE(HAVE_POSIX_TIMERS, 1, [Define this if you have POSIX timers.])],
|
|
@@ -361,6 +365,10 @@ case "$host_os" in
|
|
esac
|
|
AC_CHECK_HEADERS([sys/dvdio.h sys/cdio.h sys/scsiio.h])
|
|
|
|
+dnl ----------------------------------------------
|
|
+dnl Check for NetBSD DTV headers
|
|
+dnl ----------------------------------------------
|
|
+AC_CHECK_HEADERS([dev/dtv/dtvio.h])
|
|
|
|
dnl ----------------
|
|
dnl checks for types
|