- Require glib2>=2.4.0nb1 to get the RTLD_GLOBAL fix. - Move the plugins database from /var/cache/gstreamer-0.8 to ${PREFIX}/libdata/gstreamer-0.8, because it's intended to be updated after (de)installation of plugins only. - Implement a framework to automatically rebuild the plugins database at (de)install time. This is handled by the simple inclusion of plugins.mk in package makefiles.
13 lines
407 B
Text
13 lines
407 B
Text
$NetBSD: patch-aa,v 1.3 2004/04/06 09:30:01 jmmv Exp $
|
|
|
|
--- configure.orig 2004-03-16 12:31:54.000000000 +0100
|
|
+++ configure
|
|
@@ -24079,7 +24079,7 @@ fi;
|
|
if test "x$PLUGINS_USE_BUILDDIR" = "xyes"; then
|
|
GST_CACHE_DIR=`pwd`
|
|
else
|
|
- GST_CACHE_DIR=${localstatedir}/cache/gstreamer-$GST_MAJORMINOR
|
|
+ GST_CACHE_DIR=${localstatedir}
|
|
fi
|
|
|
|
# Check whether --with-cachedir or --without-cachedir was given.
|