78782af087
* Update enigmail to 1.7 Changelog: NEW Autocompleting email addresses now matches against any part of the name or email (bug 529584) NEW Composing a mail to a newsgroup will now autocomplete newsgroup names (bug 61491) FIXED Insecure NTLM (pre-NTLMv2) authentication disabled (see 828183) Fixed in Thunderbird 31 MFSA 2014-66 IFRAME sandbox same-origin access through redirect MFSA 2014-65 Certificate parsing broken by non-standard character encoding MFSA 2014-64 Crash in Skia library when scaling high quality images MFSA 2014-63 Use-after-free while when manipulating certificates in the trusted cache MFSA 2014-62 Exploitable WebGL crash with Cesium JavaScript library MFSA 2014-61 Use-after-free with FireOnStateChange event MFSA 2014-59 Use-after-free in DirectWrite font handling MFSA 2014-58 Use-after-free in Web Audio due to incorrect control message ordering MFSA 2014-57 Buffer overflow during Web Audio buffering for playback MFSA 2014-56 Miscellaneous memory safety hazards (rv:31.0 / rv:24.7)
32 lines
1.4 KiB
Text
32 lines
1.4 KiB
Text
$NetBSD: patch-mk,v 1.10 2014/07/27 20:04:59 ryoon Exp $
|
|
|
|
Treat DragonFly like FreeBSD.
|
|
|
|
--- mozilla/config/rules.mk.orig 2014-07-18 00:05:11.000000000 +0000
|
|
+++ mozilla/config/rules.mk
|
|
@@ -832,6 +832,7 @@ endif
|
|
ifdef DTRACE_PROBE_OBJ
|
|
EXTRA_DEPS += $(DTRACE_PROBE_OBJ)
|
|
OBJS += $(DTRACE_PROBE_OBJ)
|
|
+EXCLUDED_OBJS += $(DTRACE_PROBE_OBJ)
|
|
endif
|
|
|
|
$(filter %.$(LIB_SUFFIX),$(LIBRARY)): $(OBJS) $(EXTRA_DEPS) $(GLOBAL_DEPS)
|
|
@@ -867,7 +868,7 @@ ifdef DTRACE_PROBE_OBJ
|
|
ifndef DTRACE_LIB_DEPENDENT
|
|
NON_DTRACE_OBJS := $(filter-out $(DTRACE_PROBE_OBJ),$(OBJS))
|
|
$(DTRACE_PROBE_OBJ): $(NON_DTRACE_OBJS)
|
|
- dtrace -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(NON_DTRACE_OBJS)
|
|
+ dtrace -x nolibs -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(NON_DTRACE_OBJS)
|
|
endif
|
|
endif
|
|
endif
|
|
@@ -885,7 +886,7 @@ ifndef INCREMENTAL_LINKER
|
|
endif
|
|
ifdef DTRACE_LIB_DEPENDENT
|
|
ifndef XP_MACOSX
|
|
- dtrace -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(shell $(EXPAND_LIBS) $(MOZILLA_PROBE_LIBS))
|
|
+ dtrace -x nolibs -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(shell $(EXPAND_LIBS) $(MOZILLA_PROBE_LIBS))
|
|
endif
|
|
$(EXPAND_MKSHLIB) $(SHLIB_LDSTARTFILE) $(OBJS) $(SUB_SHLOBJS) $(DTRACE_PROBE_OBJ) $(MOZILLA_PROBE_LIBS) $(RESFILE) $(LDFLAGS) $(WRAP_LDFLAGS) $(SHARED_LIBRARY_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS) $(EXTRA_LIBS) $(DEF_FILE) $(SHLIB_LDENDFILE) $(if $(LIB_IS_C_ONLY),,$(STLPORT_LIBS))
|
|
@$(RM) $(DTRACE_PROBE_OBJ)
|