pkgsrc/editors/xemacs/patches/patch-src_config.h.in
hauke e522399242 Update to patch release 21.4.24. From the ChangeLog:
2015-03-24 Vin Shelton <acs@xemacs.org>

        * XEmacs 21.4.24 is released

2015-02-23  Vin Shelton  <acs@xemacs.org>

        * configure.in: Add LIBOSSAUDIO as appropriate.  Patch from netbsd
        via Hauke Fath.
        * configure: Rebuild.

2015-02-15  Vin Shelton  <acs@xemacs.org>

        * configure.in: Additional netbsd platform definitions.
        * configure: Rebuild.

I have used the opportunity for a bit of spring cleaning:

o remove build restrictions for powerpc and mips (hacks.mk, Makefile)
o drop the inactive X11 toolkit options - they were never used, and
  upstream does not support them for 21.4, anyway (options.mk)
o add comments to patch files
o upstream converted the texinfo files to v5 format. Patch the offenders
  to be v4 compatible
2016-04-13 13:52:27 +00:00

15 lines
491 B
C

$NetBSD: patch-src_config.h.in,v 1.3 2016/04/13 13:52:27 hauke Exp $
Always use static inline to fix build with C99 compilers.
--- src/config.h.in.orig 2015-01-29 15:04:29.000000000 +0000
+++ src/config.h.in
@@ -853,7 +853,7 @@ on various systems. */
/* Does the keyword `inline' exist? */
#undef inline
-#if defined (__cplusplus) || ! defined (__GNUC__)
+#if 1
# define INLINE_HEADER inline static
#elif defined (DONT_EXTERN_INLINE_HEADER_FUNCTIONS)
# define INLINE_HEADER inline