pkgsrc/mail/courier-mta/patches/patch-af
adam 2e85bc7502 Changes 0.68.1:
* rfc2045mkboundary.c was broken in 0.68

Changes 0.68:
* rfc2045/rfc2045mkboundary.c (rfc2045_mk_boundary): truncate
the hostname portion of the boundary to 30 chars.
* courier/doc/courier.sgml: Remove descriptions of some configuration
files that were moved to the courier-authlib package a while ago.
They don't belong here any more.
* courier/submit.C: Use the authenticated address, instead of the
return address, for domain-based virtual configuration.
* courier/libs/cfilename.c (config_has_vhost): Checks whether
vhost.[ip] exists.
* courier/module.esmtp/courieresmtpd.c (main): Only set a message's
virtual host if vhost.[ip] exists.
* courier/module.esmtp/esmtpclient.c (get_sourceaddr): Make sure the
input buffer is null-terminated.
* courier/submit.C (getrcpts): If there's no vhost setting from the
sender's IP address (this includes local mail!) if vhost.domain exists,
use [domain] as the virtual host.
* Remove config_search(), which simply called config_localfilename().
Change all current callers to call config_localfilename().
* courier/libs/cfilename.c (config_set_local_vhost): saves a string
that gets appended as a suffix, by config_localfilename(), and if that
filename exists, that's returned as the filename, otherwise it's the
original string without the suffix. config_get_local_vhost() returns
the suffix string.
to config_set_local_vhost().
* courier/libs/comsubmitclient.c (submit_fork): If
config_get_local_vhost(), add a -vhost parameter to submit().
* courier/submit.C (cppmain): -vhost sets config_set_local_vhost().
* courier/submit2.C (closectl): New COMCTLFILE_VHOST parameter in the
config file, taken from the vhost setting.
* courier/libs/comctlfile.c (ctlfile_setvhost): If COMCTLFILE_VHOST is
set, call ctlfile_setvhost(), return an indication if the vhost has
changed. Absence of a COMCTLFILE_VHOST treated as a discrete "(null)"
setting.
* courier/module.esmtp/esmtpclient.c (esmtpchild): If ctlfile_setvhost()
then disconnect the current socket, if one is open.
* courier/module.esmtp/esmtpclient.c (get_sourceaddr): The IP address
specified in ipout or ip6out overrides SOURCE_ADDRESS and
SOURCE_ADDRESS_IPV6 environment variable.
* courier/module.local/localmail.c (main): Call ctlfile_setvhost().
* courier/module.uucp/uucp.c (uux): Call ctlfile_setvhost().
* courier/module.dsn/dsn.c (main): Call ctlfile_setvhost().
* liblock/mail.c (dotlock_exists): Quell a compiler warning.
* courier/courierd.dist.in SOURCE_ADDRESS: Add a note that this setting
is deprecated.
2012-06-09 11:45:38 +00:00

14 lines
623 B
Text

$NetBSD: patch-af,v 1.5 2012/06/09 11:45:38 adam Exp $
--- courier/filters/perlfilter/Makefile.in.orig Sat Jul 21 20:31:15 2007
+++ courier/filters/perlfilter/Makefile.in
@@ -233,7 +233,8 @@ top_srcdir = @top_srcdir@
EXTRA_DIST = perlfilter-wrapper.pl perlfilter-example.pl
BUILT_SOURCES = filtersocketdir.h wrapperpl.h xsinit.c
CLEANFILES = $(BUILT_SOURCES) permissions.dat
-filterbindir = $(libexecdir)/filters
+pkglibexecdir = $(libexecdir)/courier
+filterbindir = $(pkglibexecdir)/filters
filterbin_PROGRAMS = @perlfilter_prog@
scriptdir = $(datadir)
script_SCRIPTS = perlfilter-wrapper.pl perlfilter-example.pl