pkgsrc/devel/mit-pthreads/patches/patch-ah
tron b1e841e86a Link shared library with "/usr/lib/c++rt0.o" on a.out systems to make sure
that pthread_init() gets called. Fixes PR pkg/7433 by Andreas Gustafsson.
1999-05-02 19:46:16 +00:00

35 lines
1 KiB
Text

$NetBSD: patch-ah,v 1.5 1999/05/02 19:46:16 tron Exp $
--- config/Makefile.in.orig Fri Mar 22 05:29:54 1996
+++ config/Makefile.in Sun May 2 21:19:49 1999
@@ -18,8 +18,8 @@
# Standard bsd install rules look for the "install" program, rather than
# using some variable. So, hack things so that that install rule works.
-BINGRP != echo " " `groups` " " | sed 's/ [0-9][0-9]* / /g' | awk '{print $$1}'
-BINOWN != echo $${USER}
+#BINGRP != echo " " `groups` " " | sed 's/ [0-9][0-9]* / /g' | awk '{print $$1}'
+#BINOWN != echo $${USER}
LIBMODE = 644 # so ranlib can run!
.include "config.flags"
@@ -29,7 +29,7 @@
# pathname for srcdir here, and live with it.
srcdir = $(srctop)
-beforeinstall:: install-dirs
+beforeinstall: install-dirs
.include "${srcdir}/pthreads/Makefile.inc"
.include "${srcdir}/stdlib/Makefile.inc"
@@ -38,6 +38,10 @@
.include "${srcdir}/gen/Makefile.inc"
.include "${srcdir}/net/Makefile.inc"
.include "${srcdir}/scripts/Makefile.inc"
+
+.if (${OBJECT_FMT} == "a.out")
+SOBJS+= /usr/lib/c++rt0.o
+.endif
.include <bsd.lib.mk>