pkgsrc/databases/rrdtool/patches/patch-al
adam e1339d6190 Changes 1.4.4:
Bugfixes:
* compile: multiple fixes isnan and isinf defines to make rrdtool compile
  with gcc on solaris (with --disable-nls)
* handle gettext/libintl like any other feature, do not try to supply
  our own ... rrdtool can work fine without it
* rrd_client: fix potential segfaults
* rrd_client: resolve synmlinks properly
* compile: fix libtool and libtoolize names for OSX compiles
* compile: fix for HAVE_BROKEN_MS_ASYNC (old linux kernels)
* rrd_xport: fix --daemon handling
* rrd_client: explicitly close connection on error
* rrd_update: fix memory leak for COMPUTE datasources
* rrd_daemon: fix segfault when specifying a relative path (-j option)
* compile: make rrdtool compile with gcc 4.5
* portability: use %lld (long long int) for time_t *printf
* compile: link pangocairo and not pango since we do use pangocairo actually
* compile: re-integrate intl into compile dependency so that hosts with
  old (or no) gettext can get access to the included copy.
* rrd_cached: exit with status !=0 on invalid cli

Enhancements:
* updated build files and instructions for win32 port by Chris Larsen
* legal: Relicense the RRDCacheD client interface under the MIT license
* legal: Updted FLOSS Exception for latest PHP license
* rrd_cached: better help output
2010-07-06 07:31:20 +00:00

15 lines
514 B
Text

$NetBSD: patch-al,v 1.17 2010/07/06 07:31:20 adam Exp $
Correct examples directory.
--- examples/Makefile.in.orig 2010-07-05 19:31:54.000000000 +0000
+++ examples/Makefile.in
@@ -330,7 +330,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
SUBDIRS = rrdcached
EXTRA_DIST = cgi-demo.cgi.in
-examplesdir = $(pkgdatadir)/examples
+examplesdir = $(prefix)/share/examples/rrdtool
examples_SCRIPTS = cgi-demo.cgi piped-demo.pl shared-demo.pl \
stripes.pl bigtops.pl minmax.pl 4charts.pl perftest.pl