14f579a85a
* Include mk/atomic64.mk to add -march=i586 to CFLAGS and pass CFLAGS to gyp. Fix PR pkg/56025 in another way. * Use external devel/protobuf to avoid internal protobuf build. So bump PKGREVISION. * dictionary/pos_matcher.h does not generated before its use sometimes. Generate it explicitly with dictionary/dictionary_base.gyp:text_dictionary_loader target for mozc-server.
17 lines
451 B
Python
17 lines
451 B
Python
$NetBSD: patch-protobuf_protobuf.gyp,v 1.7 2021/02/27 04:19:46 ryoon Exp $
|
|
|
|
* Pass LDFLAGS from pkgsrc.
|
|
Fix -lprotobuf is not found error.
|
|
|
|
--- protobuf/protobuf.gyp.orig 2021-02-15 05:04:33.000000000 +0000
|
|
+++ protobuf/protobuf.gyp
|
|
@@ -156,6 +156,9 @@
|
|
'libraries': [
|
|
'-lprotobuf',
|
|
],
|
|
+ 'ldflags': [
|
|
+ '<!(echo $LDFLAGS)',
|
|
+ ],
|
|
},
|
|
},
|
|
{ # else
|