3a9ea86baa
Tested compilation on i386 (a.out) and alpha (ELF). Note the usage of libtool is not normal.
20 lines
599 B
Text
20 lines
599 B
Text
$NetBSD: patch-aa,v 1.2 2002/05/07 13:18:27 itohy Exp $
|
|
|
|
--- configure.in.orig Sat Dec 29 01:34:30 2001
|
|
+++ configure.in Fri Mar 22 13:15:31 2002
|
|
@@ -19,6 +19,15 @@
|
|
AC_PROG_INSTALL
|
|
AC_PATH_PROG(GS,gs,gs)
|
|
|
|
+dnl Look for extra libraries used by libplotter
|
|
+AC_PATH_XTRA
|
|
+AC_SUBST(X_CFLAGS)
|
|
+DEPLIBS="`$LIBTOOL -n cc -o xx xx.o $LIBPLOTTERLA | tr ' ' '\012' | sed -e '/^-[[LWl]]/!d' -e '/^-lplotter$/d' | tr '\012' ' '`"
|
|
+
|
|
+LDLIBS="$DEPLIBS $LDLIBS"
|
|
+LIBS="$DEPLIBS"
|
|
+CPPFLAGS="$X_CFLAGS $CPPFLAGS"
|
|
+
|
|
dnl Look for various optional libraries.
|
|
AC_CHECK_LIB(dl,main,[LDL=-ldl],[LDL=])
|
|
AC_SUBST(LDL)
|