16 lines
763 B
Text
16 lines
763 B
Text
$NetBSD: patch-dm,v 1.1 2005/12/30 21:35:58 joerg Exp $
|
|
|
|
diff -ruN ../Orig/mozilla/security/nss/cmd/platlibs.mk ./security/nss/cmd/platlibs.mk
|
|
--- ../Orig/mozilla/security/nss/cmd/platlibs.mk 2005-04-07 06:35:41.000000000 +0900
|
|
+++ ./security/nss/cmd/platlibs.mk 2005-12-04 19:44:52.000000000 +0900
|
|
@@ -186,8 +186,8 @@
|
|
# If GNU ld is used, we must use the -rpath-link option to tell
|
|
# the linker where to find libsoftokn3.so, an implicit dependency
|
|
# of libnss3.so.
|
|
-ifeq (,$(filter-out BSD_OS FreeBSD Linux NetBSD, $(OS_ARCH)))
|
|
-EXTRA_SHARED_LIBS += -Wl,-rpath-link,$(DIST)/lib
|
|
+ifeq (,$(filter-out BSD_OS FreeBSD Linux NetBSD DragonFly, $(OS_ARCH)))
|
|
+EXTRA_SHARED_LIBS += -Wl,-rpath-link,$(DIST)/lib -R/usr/pkg/lib/firefox
|
|
endif
|
|
|
|
ifeq ($(OS_ARCH), SunOS)
|