8837ca2844
changes: Prevent out of range scalefactors Updated to latest mpeg4ip mp4 file format library Added -s option to make the encoder output optimized mp4 layout Improved JPEG detection for album art Lot's of compilation issues solved
21 lines
758 B
Text
21 lines
758 B
Text
$NetBSD: patch-ab,v 1.2 2009/09/09 16:40:39 drochner Exp $
|
|
|
|
--- configure.in.orig 2009-02-05 01:55:38.000000000 +0100
|
|
+++ configure.in
|
|
@@ -28,6 +28,7 @@ AC_CHECK_DECL(strcasecmp, MY_DEFINE(HAVE
|
|
AC_CHECK_LIB(gnugetopt, getopt_long)
|
|
|
|
AM_CONDITIONAL(WITH_MP4V2, false)
|
|
+AM_CONDITIONAL(WITH_EXTMP4V2, false)
|
|
|
|
AC_CHECK_DECLS([MP4Create, MP4MetadataDelete],
|
|
AC_CHECK_LIB(mp4v2, MP4MetadataDelete, external_mp4v2=yes,
|
|
@@ -36,6 +37,8 @@ AC_CHECK_DECLS([MP4Create, MP4MetadataDe
|
|
|
|
if test x$external_mp4v2 = xyes; then
|
|
AC_MSG_NOTICE([*** Building with external mp4v2 ***])
|
|
+ MY_DEFINE(HAVE_LIBMP4V2)
|
|
+ AM_CONDITIONAL(WITH_EXTMP4V2, true)
|
|
else
|
|
if test x$WITHMP4V2 = xyes; then
|
|
AC_MSG_NOTICE([*** Building with internal mp4v2 ***])
|