c5256d94ca
Both the omniORB package and py-omniORBpy install files into ${PYSITELIB}/omniidl_be, but the only files that conflicts are __init__.py with the comment "Empty file to convince Python that this is a module." and __init__.pyc. So if this package is being built with the same PYTHON_VERSION_DEFAULT as omniORB was simply don't install the __int__.py{,c} files.
16 lines
373 B
Makefile
16 lines
373 B
Makefile
$NetBSD: patch-omniidl__be_dir.mk,v 1.1 2012/02/28 07:20:21 sbd Exp $
|
|
|
|
--- omniidl_be/dir.mk.orig 2003-03-23 21:51:59.000000000 +0000
|
|
+++ omniidl_be/dir.mk
|
|
@@ -6,7 +6,10 @@ ifeq ($(PYTHON),)
|
|
PYTHON = python
|
|
endif
|
|
|
|
-FILES = __init__.py python.py
|
|
+FILES = python.py
|
|
+ifdef INSTALL_OMNIIDL_BE_INIT
|
|
+FILES += __init__.py
|
|
+endif
|
|
|
|
export:: $(FILES)
|
|
@(dir="$(PYLIBDIR)"; \
|