pkgsrc/databases/mysql57-client/patches/patch-storage_federated_CMakeLists.txt
adam 7cb1f0a9d9 MySQL is a SQL (Structured Query Language) database server. SQL is the most
popular database language in the world. MySQL is a client-server implementation
that consists of a server daemon `mysqld' and many different client
programs/libraries.

The main goals of MySQL are speed and robustness.

The base upon which MySQL is built is a set of routines that have been used in
a highly demanding production environment for many years.  While MySQL is still
in development it already offers a rich and highly useful function set.
2016-09-16 06:49:11 +00:00

12 lines
510 B
Text

$NetBSD: patch-storage_federated_CMakeLists.txt,v 1.1 2016/09/16 06:49:11 adam Exp $
Build with newer DTrace.
--- storage/federated/CMakeLists.txt.orig 2016-03-28 18:06:12.000000000 +0000
+++ storage/federated/CMakeLists.txt
@@ -22,4 +22,4 @@ IF(NOT WITH_FEDERATED AND NOT WITH_FEDER
SET(FEDERATED_SOURCES ${FEDERATED_SOURCES} ${CMAKE_SOURCE_DIR}/mysys/string.c)
ENDIF()
MYSQL_ADD_PLUGIN(federated ${FEDERATED_SOURCES} STORAGE_ENGINE
-RECOMPILE_FOR_EMBEDDED)
+RECOMPILE_FOR_EMBEDDED DTRACE_INSTRUMENTED)