204621bf62
Some of the highlights in release 3.12 are: * Polymorphic recursion is supported, using explicit type declarations on the recursively-defined identifiers. * First-class modules: module expressions can be embedded as values of the core language, then manipulated like any other first-class value, then projected back to the module level. * New operator to modify a signature a posteriori: S with type t := tau denotes signature S where the t type component is removed and substituted by the type tau elsewhere. * New notations for record expressions and record patterns: { lbl } as shorthand for { lbl = lbl }, and { ...; _ } marks record patterns where some labels were intentionally omitted. * Local open let open ... in ... now supported by popular demand. * Type variables can be bound as type parameters to functions; such types are treated like abstract types within the function body, and like type variables (possibly generalized) outside. * The module type of construct enables to recover the module type of a given module. * Explicit method override using the method! keyword, with associated warnings and errors.
37 lines
1.5 KiB
Text
37 lines
1.5 KiB
Text
$NetBSD: patch-bh,v 1.4 2010/08/19 08:06:53 asau Exp $
|
|
|
|
--- otherlibs/labltk/lib/Makefile.orig 2010-06-08 04:54:09.000000000 +0400
|
|
+++ otherlibs/labltk/lib/Makefile 2010-08-12 14:39:56.000000000 +0400
|
|
@@ -58,26 +58,21 @@
|
|
@echo 'exec $(INSTALLDIR)/$(LIBNAME)top$(EXE) -I $(INSTALLDIR) $$*' >> $@
|
|
|
|
install-script: $(LIBNAME)
|
|
- cp $(LIBNAME) $(BINDIR)
|
|
- chmod 755 $(BINDIR)/$(LIBNAME)
|
|
+ $(BSD_INSTALL_SCRIPT) $(LIBNAME) $(BINDIR)
|
|
|
|
install-batch:
|
|
cp labltk.bat $(BINDIR)
|
|
|
|
install:
|
|
- if test -d $(INSTALLDIR); then : ; else mkdir $(INSTALLDIR); fi
|
|
- cp $(LIBNAME).cma $(LIBNAME)top$(EXE) $(INSTALLDIR)
|
|
- chmod 644 $(INSTALLDIR)/$(LIBNAME).cma
|
|
- chmod 755 $(INSTALLDIR)/$(LIBNAME)top$(EXE)
|
|
- @if test -d $(BINDIR); then : ; else mkdir $(BINDIR); fi
|
|
+ if test -d $(INSTALLDIR); then : ; else $(BSD_INSTALL_DATA_DIR) $(INSTALLDIR); fi
|
|
+ $(BSD_INSTALL_DATA) $(LIBNAME).cma $(LIBNAME)top$(EXE) $(INSTALLDIR)
|
|
+ @if test -d $(BINDIR); then : ; else $(BSD_INSTALL_DATA_DIR) $(BINDIR); fi
|
|
@case x$(TOOLCHAIN) in \
|
|
xmingw|xmsvc) $(MAKE) install-batch ;; \
|
|
*) $(MAKE) install-script ;; \
|
|
esac
|
|
|
|
installopt:
|
|
- @if test -d $(INSTALLDIR); then : ; else mkdir $(INSTALLDIR); fi
|
|
- cp $(LIBNAME).cmxa $(LIBNAME).$(A) $(INSTALLDIR)
|
|
+ @if test -d $(INSTALLDIR); then : ; else $(BSD_INSTALL_DATA_DIR) $(INSTALLDIR); fi
|
|
+ $(BSD_INSTALL_DATA) $(LIBNAME).cmxa $(LIBNAME).$(A) $(INSTALLDIR)
|
|
cd $(INSTALLDIR); $(RANLIB) $(LIBNAME).$(A)
|
|
- chmod 644 $(INSTALLDIR)/$(LIBNAME).cmxa
|
|
- chmod 644 $(INSTALLDIR)/$(LIBNAME).$(A)
|