323caf52eb
Based on patch provided by Zafer Aydogan via private mail. This update to 2.6.1 contains all patches from the Debian package: - various bug fixes - uploading under the temporary name `weex.tmp' with the RenameOK option - support for FTP proxy server that requires challenge/response - The i386 RPM was compiled on RedHat 9 - You should be able to "rpmbuild --rebuild" the SRPM on older RedHat releases or other RPM based distros. pkgsrc changes: * project now on sourceforge * no need patch to fix localedir (patch-ac) * need msgfmt to build * need gettext-lib * add DESTDIR support
25 lines
878 B
Text
25 lines
878 B
Text
$NetBSD: patch-ac,v 1.2 2008/04/19 05:38:16 obache Exp $
|
|
|
|
--- po/Makefile.in.in.orig 2000-04-24 14:44:53.000000000 +0000
|
|
+++ po/Makefile.in.in
|
|
@@ -111,9 +111,9 @@ install-data: install-data-@USE_NLS@
|
|
install-data-no: all
|
|
install-data-yes: all
|
|
if test -r "$(MKINSTALLDIRS)"; then \
|
|
- $(MKINSTALLDIRS) $(datadir); \
|
|
+ $(MKINSTALLDIRS) $(DESTDIR)$(datadir); \
|
|
else \
|
|
- $(SHELL) $(top_srcdir)/mkinstalldirs $(datadir); \
|
|
+ $(SHELL) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(datadir); \
|
|
fi
|
|
@catalogs='$(CATALOGS)'; \
|
|
for cat in $$catalogs; do \
|
|
@@ -123,7 +123,7 @@ install-data-yes: all
|
|
*) destdir=$(localedir);; \
|
|
esac; \
|
|
lang=`echo $$cat | sed 's/\$(CATOBJEXT)$$//'`; \
|
|
- dir=$$destdir/$$lang/LC_MESSAGES; \
|
|
+ dir=$(DESTDIR)$$destdir/$$lang/LC_MESSAGES; \
|
|
if test -r "$(MKINSTALLDIRS)"; then \
|
|
$(MKINSTALLDIRS) $$dir; \
|
|
else \
|