pkgsrc/mail/mairix/patches/patch-aa
tonio 55ee3daef0 Update mail/mairix to 0.20 (ok simonb@)
Changelog:
Version 0.20 	20 March 2007
    * Cache uncompressed mbox data (Chris Mason, further work by me)
    * Fix gaps in date ranges for search
    * Unlock database if mairix is interrupted (Paul Fox)
    * Add fast index option (-F)
    * Fix conditional compilation errors for compressed mbox
    * Reimplement MIME header parsing
    * Add capability to search on names of attachments
    * Add capability to search on state of message flags
    * Create maildir-format mfolder filenames correctly with regard to flags
    * Various bug fixes (Oliver Braun, Matthias Teege)
Version 0.19 	15 July 2006
    * mairix.spec fixes (André Costa)
    * bug fix: freeing of message structures (Karsten Petersen)
    * Add new -x (--excerpt-output) option, an alternative mode for searching. This displays the key headers from the matching messages on stdout.
    * Add notes about the mairix-users mailing list and the SourceForge page to README.
    * Fix configuration + compilation to allow building with gzip support but without bzlib support.
    * Rename internal functions like zopen() to avoid name conflicts on MacOS X. (Vincent Lefevre)
    * Remove a spurious ; in bison input file (Vincent Lefevre)
    * Improve output given in various error conditions (based on patch by Karsten Petersen)
Version 0.18 	10 March 2006
    * Support bzip2'd mbox folders
    * Fix bugs in parsing mbox folders containing unquoted 'From ' lines inside MIME body parts
    * Fix bug in parsing content-type data containing quotes with whitespace before
    * Clone the message flags (when both the source folder and mfolder are both of maildir type)
    * New manpages mairix.1 and mairixrc.5 are included, and the old texinfo-based documentation is deprecated into the old_docs/ directory.
    * Upgrade scanners to new version of dfasyn
    * Support Mew's MH folder subtype
Version 0.17.1 	16 December 2005
    * Fix detection of MH folder subtype used by nnml (Gnus)
    * Fix filename format generated in the /cur/ directory for maildir mfolders.
    * Syntax fix in configure script
Version 0.17 	14 November 2005
    * Support gzipped mbox folders (any file matched by a mbox= line in the config file is considered as a gzipped mbox if its name ends in .gz)
    * Rework directory traversal for the '...' construct to speed up indexing and the check that mfolder isn't going to overwrite a real folder when searching.
    * Check whether database exists before attempting to do searching.
    * Matched new maildir messages go in /new/ subdirectory of maildir mfolder.
    * Fix lots of compiler warnings generated by gcc4.x
    * Don't create and immediately scrub database entries for empty mbox folders.
    * Fix usage() info for bare word in searching
    * Allow '.' on the ends of numeric filenames in MH folders (to work with Evolution)
    * Update .PHONY target so that 'make install' etc are more reliable.
    * Add --version switch
    * Fix bug with size argument passed to memset
    * Add X-source-folder header to indicate the original folder of a match found in an mbox.
2007-06-12 15:23:48 +00:00

29 lines
909 B
Text

$NetBSD: patch-aa,v 1.1 2007/06/12 15:23:48 tonio Exp $
--- Makefile.in.orig 2007-02-09 00:03:48.000000000 +0100
+++ Makefile.in
@@ -90,17 +90,13 @@ distclean: clean
-rm -f Makefile config.log
install:
- [ -d $(prefix) ] || mkdir -p $(prefix)
- [ -d $(bindir) ] || mkdir -p $(bindir)
- [ -d $(mandir) ] || mkdir -p $(mandir)
- [ -d $(man1dir) ] || mkdir -p $(man1dir)
- [ -d $(man5dir) ] || mkdir -p $(man5dir)
- cp -f mairix $(bindir)
- chmod 555 $(bindir)/mairix
- cp -f mairix.1 $(man1dir)
- chmod 444 $(man1dir)/mairix.1
- cp -f mairixrc.5 $(man5dir)
- chmod 444 $(man5dir)/mairixrc.5
+ ${BSD_INSTALL_PROGRAM_DIR} $(bindir)
+ ${BSD_INSTALL_MAN_DIR} $(mandir)
+ ${BSD_INSTALL_MAN_DIR} $(man1dir)
+ ${BSD_INSTALL_MAN_DIR} $(man5dir)
+ ${BSD_INSTALL_PROGRAM} mairix $(bindir)
+ ${BSD_INSTALL_MAN} mairix.1 $(man1dir)
+ ${BSD_INSTALL_MAN} mairixrc.5 $(man5dir)
.PHONY : all install clean distclean