5f6e6b5e4c
-update to 1.25 which contains small bug fixes according to the notes -the most serious change seems to be that faac comes with an own copy of libmp4v2 now which it tries to use exclusively -- add some patches to still use an external lib (that's all optional, needed for tagging support)
30 lines
1.1 KiB
Text
30 lines
1.1 KiB
Text
$NetBSD: patch-ab,v 1.1 2007/02/09 20:27:16 drochner Exp $
|
|
|
|
--- configure.in.orig 2006-08-13 16:17:26.000000000 +0200
|
|
+++ configure.in
|
|
@@ -27,6 +27,7 @@ AC_CHECK_DECL(strcasecmp, MY_DEFINE(HAVE
|
|
AC_CHECK_LIB(gnugetopt, getopt_long)
|
|
|
|
AM_CONDITIONAL(WITH_MP4V2, false)
|
|
+AM_CONDITIONAL(WITH_EXTMP4V2, false)
|
|
|
|
AC_CHECK_DECLS([MP4Create, MP4MetadataDelete],
|
|
AC_CHECK_LIB(mp4v2, MP4MetadataDelete, external_mp4v2=yes,
|
|
@@ -35,6 +36,8 @@ AC_CHECK_DECLS([MP4Create, MP4MetadataDe
|
|
|
|
if test x$external_mp4v2 = xyes; then
|
|
AC_MSG_NOTICE([*** Building with external mp4v2 ***])
|
|
+ MY_DEFINE(HAVE_LIBMP4V2)
|
|
+ AM_CONDITIONAL(WITH_EXTMP4V2, true)
|
|
else
|
|
if test x$WITHMP4V2 = xyes; then
|
|
AC_MSG_NOTICE([*** Building with internal mp4v2 ***])
|
|
@@ -66,6 +69,6 @@ AC_CHECK_TYPES([in_port_t, socklen_t], ,
|
|
#include <netinet/in.h>])
|
|
AC_CHECK_MEMBERS(fpos_t.__pos,,, [#include <stdio.h>])
|
|
|
|
-AC_OUTPUT(common/Makefile common/mp4v2/Makefile \
|
|
- libfaac/Makefile frontend/Makefile \
|
|
+AC_OUTPUT(common/Makefile common/mp4v2/Makefile
|
|
+ libfaac/Makefile frontend/Makefile
|
|
include/Makefile Makefile)
|