f8a0903fc5
New Features and Changes: ======================== o The following Vdata routines were added: VSsetblocksize/vsfsetblsz -- sets the block size of the linked-block element. VSsetnumblocks/vsfsetnmbl -- sets the number of blocks for a linked-block element. VSgetblockinfo/vsfgetblinfo -- retrieves the block size and the number of blocks of a linked-block element. o Two routines were added to get compression information for the SD and GR interfaces, including chunked elements: SDgetcompress/sfgcompress and GRgetcompress/mggcompress. Note: - For a JPEG image, GRgetcompress only returns the compression type, not the compression information (i.e, quantity and force_baseline). This information is not currently retrievable. - Getting compression type for JPEG chunked images is not working yet. o "hdp dumpgr" has a new option, -pd, to print palette data only. Also, whenever option -p or -pd is given, only palettes are printed, and no images or file attributes. o A new FORTRAN function, heprntf (HEprint), was added. It takes two arguments: file name and level. If the file name string has 0 length, then error messages will be printed to standard output. o A memory leak in the netCDF portion of the HDF/mfhdf distribution was fixed. o The "#define NULL" was removed since ANSI C compilers are required to define NULL. o When using "hdp dumpgr", data was being printed in the range of 0-250 when it should have been between 0-168. This problem is now fixed.
39 lines
939 B
Text
39 lines
939 B
Text
$NetBSD: patch-ai,v 1.6 2002/05/03 23:14:52 jtb Exp $
|
|
|
|
--- /dev/null Wed May 1 14:20:26 2002
|
|
+++ mfhdf/ncdump/Makefile Wed May 1 14:24:12 2002
|
|
@@ -0,0 +1,34 @@
|
|
+PROG= ncdump
|
|
+PROGNAME= hdfncdump
|
|
+
|
|
+MAN= hdfncdump.1
|
|
+
|
|
+SRCS= ncdump.c vardata.c dumplib.c
|
|
+
|
|
+BINDIR= ${PREFIX}/bin
|
|
+LIBDIR= ${PREFIX}/lib
|
|
+MANDIR= ${PREFIX}/man
|
|
+CFLAGS= -g
|
|
+CPPFLAGS+= -I${.CURDIR}/../libsrc
|
|
+
|
|
+LDFLAGS+= -L${.CURDIR}/../libsrc
|
|
+LDFLAGS+= -L${.CURDIR}/../../hdf/src
|
|
+LDFLAGS+= -Wl,-R${BUILDLINK_PREFIX.jpeg}/lib
|
|
+LDFLAGS+= -Wl,-R${BUILDLINK_PREFIX.zlib}/lib
|
|
+
|
|
+LDADD+= -lmfhdf -ldf -ljpeg -lz
|
|
+
|
|
+NOGCCERROR= 1
|
|
+
|
|
+NCGEN= ${.CURDIR}/../ncgen/ncgen
|
|
+
|
|
+test: ${PROG} test0.cdl
|
|
+ ${NCGEN} -o test0.nc -n test0.cdl
|
|
+ ./${PROG} test0.nc > test1.cdl
|
|
+ ${NCGEN} -o test1.nc -n test1.cdl
|
|
+ ./${PROG} -n test0 test1.nc > test2.cdl
|
|
+ @cmp test1.cdl test2.cdl && \
|
|
+ echo "*** ${PROG} test successful ***" ; \
|
|
+ rm test1.cdl test1.nc test2.cdl
|
|
+
|
|
+.include <bsd.prog.mk>
|