pkgsrc/devel/py-isort/patches/patch-setup.py
fhajny c8ea164954 Import isort 4.2.5 as devel/py-isort.
isort is a Python utility / library to sort imports alphabetically,
and automatically separated into sections. It provides a command
line utility, Python library and plugins for various editors to
quickly sort all your imports.
2017-02-28 20:54:09 +00:00

15 lines
524 B
Python

$NetBSD: patch-setup.py,v 1.1 2017/02/28 20:54:09 fhajny Exp $
Use PYVERSSUFFIX with scripts.
--- setup.py.orig 2016-03-30 11:08:25.000000000 +0000
+++ setup.py
@@ -49,7 +49,7 @@ setup(name='isort',
license="MIT",
entry_points={
'console_scripts': [
- 'isort = isort.main:main',
+ 'isort' + sys.version[0:3] + ' = isort.main:main',
],
'distutils.commands': ['isort = isort.main:ISortCommand'],
'pylama.linter': ['isort = isort.pylama_isort:Linter'],