- don't use ALT_JDK_IMPORT_PATH on SunOS, just build like on other platforms - regen all bootstraps to facilitate removal of the +UseSerialGC hacks - bootstrap binaries on FTP are now PGP signed - remove a handful of obsolete patches
28 lines
796 B
Text
28 lines
796 B
Text
$NetBSD: patch-jdk_test_Makefile,v 1.5 2015/03/02 03:53:26 tnn Exp $
|
|
|
|
Use tools from pkgsrc.
|
|
|
|
--- jdk/test/Makefile.orig 2014-01-01 05:53:43.000000000 +0000
|
|
+++ jdk/test/Makefile
|
|
@@ -54,6 +54,8 @@ UNAME = uname
|
|
UNIQ = uniq
|
|
WC = wc
|
|
ZIP = zip
|
|
+UNZIP = unzip
|
|
+WHICH = which
|
|
|
|
# Get OS name from uname
|
|
UNAME_S := $(shell $(UNAME) -s)
|
|
@@ -381,6 +383,12 @@ else
|
|
JTREG_TEST_OPTIONS = $(JAVA_ARGS:%=-javaoptions:%) $(JAVA_VM_ARGS:%=-vmoption:%)
|
|
endif
|
|
|
|
+# carry over XAUTHORITY
|
|
+JTREG_TEST_OPTIONS += -e:XAUTHORITY
|
|
+
|
|
+# some tests expect to find zip and unzip on the path
|
|
+JTREG_TEST_OPTIONS += -e:PATH=/bin:/usr/bin:$(dir $(shell $(WHICH) $(ZIP))):$(dir $(shell $(WHICH) $(UNZIP)))
|
|
+
|
|
ifdef CONCURRENCY
|
|
EXTRA_JTREG_OPTIONS += -concurrency:$(CONCURRENCY)
|
|
endif
|