Changes to squid-2.7.STABLE6 (4 February 2009) - Bug #2494: Fix tproxy url in configure - Correct latency measurements - Correct upgrade_http0.9 example - Correct parsing of invalid http version numbers - Crossreference authenticate_ip_shortcircuit_access and authenticate_ip_shortcircuit_ttl - Add in some better documentation for override-expire.
56 lines
1.8 KiB
Text
56 lines
1.8 KiB
Text
$NetBSD: patch-ab,v 1.2 2009/02/05 13:43:06 taca Exp $
|
|
|
|
--- configure.in.orig 2009-02-04 09:44:06.000000000 +0900
|
|
+++ configure.in
|
|
@@ -1635,11 +1635,13 @@ AC_CHECK_HEADERS(
|
|
libc.h \
|
|
linux/netfilter_ipv4.h \
|
|
linux/netfilter_ipv4/ip_tproxy.h \
|
|
+ machine/byte_swap.h \
|
|
malloc.h \
|
|
math.h \
|
|
memory.h \
|
|
mount.h \
|
|
net/if.h \
|
|
+ net/pf/pfvar.h \
|
|
net/pfvar.h \
|
|
netdb.h \
|
|
netinet/if_ether.h \
|
|
@@ -2004,7 +2006,16 @@ AC_CHECK_SYSTYPE(size_t, unsigned int)
|
|
AC_CHECK_SYSTYPE(ssize_t, int)
|
|
AC_CHECK_SYSTYPE(off_t, int)
|
|
AC_CHECK_SYSTYPE(mode_t, unsigned short)
|
|
-AC_CHECK_SYSTYPE(fd_mask, int)
|
|
+
|
|
+dnl Check for type fd_mask
|
|
+AC_CACHE_CHECK(for fd_set,ac_cv_have_fd_mask, [
|
|
+ AC_TRY_COMPILE([#include <sys/types.h>
|
|
+#include <sys/time.h>
|
|
+#include <sys/unistd.h>],
|
|
+ [fd_mask fds;],
|
|
+ ac_cv_have_fd_mask="yes",
|
|
+ ac_cv_have_fd_mask="no")
|
|
+])
|
|
|
|
AC_CHECK_SIZEOF_SYSTYPE(off_t, 4)
|
|
AC_CHECK_SIZEOF_SYSTYPE(size_t, 4)
|
|
@@ -2299,8 +2310,8 @@ if test "$GCC" = "yes"; then
|
|
GCCVER=`$CC -v 2>&1 | awk '$2 == "version" {print $3}'`
|
|
case "$GCCVER" in
|
|
[2.95.[123]])
|
|
- echo "Removing -O for gcc on $host with GCC $GCCVER"
|
|
- CFLAGS="`echo $CFLAGS | sed -e 's/-O[[0-9]]*//'`"
|
|
+ echo "Making -O\[[2-9\]] to -O for gcc on $host with GCC $GCCVER"
|
|
+ CFLAGS="`echo $CFLAGS | sed -e 's/-O[[0-9]]*/-O/'`"
|
|
;;
|
|
esac
|
|
fi
|
|
@@ -2697,7 +2708,7 @@ dnl PF support requires a header file.
|
|
if test "$PF_TRANSPARENT" ; then
|
|
AC_MSG_CHECKING(if PF header file is installed)
|
|
# hold on to your hats...
|
|
- if test "$ac_cv_header_net_pfvar_h" = "yes"; then
|
|
+ if test "$ac_cv_header_net_pfvar_h" = "yes" || test "$ac_cv_header_net_pf_pfvar_h" = "yes"; then
|
|
PF_TRANSPARENT="yes"
|
|
AC_DEFINE(PF_TRANSPARENT, 1, [Enable support for Transparent Proxy on systems using PF address
|
|
redirection. This provides "masquerading" support for OpenBSD.])
|