pkgsrc/lang/STk/patches/patch-ao
2015-12-29 23:34:43 +00:00

34 lines
1.5 KiB
Text

$NetBSD: patch-ao,v 1.3 2015/12/29 23:34:43 dholland Exp $
Honor pkgsrc LDFLAGS.
Avoid using absolute symbolic links. (in concert with pkg makefile)
--- Src/Makefile.in.orig 1999-09-03 16:21:32.000000000 -0400
+++ Src/Makefile.in 2008-09-06 20:03:00.000000000 -0400
@@ -47,7 +47,7 @@ TCLLIB = ../Tcl/libtcl.a
EVTCLLIB = ../Tcl/libevtcl.a
MPLIB = ../Mp/$(MP).a
STACKLIB = ../Stack/libstack.a
-LIBS = @LIBS@ $(LIB_DLD) $(LIB_MALLOC)
+LIBS = ${X11_LDFLAGS} @LIBS@ $(LIB_DLD) $(LIB_MALLOC)
ALLIBS = $(MPLIB) $(STACKLIB) $(TKLIB) $(TCLLIB) $(EVTCLLIB)
SALLLIBS = $(MPLIB) $(STACKLIB) $(TCLLIB)
@@ -111,7 +111,7 @@ install.stk: stk
-if [ ! -d $(root)$(bindir) ] ; then mkdir -p $(root)$(bindir); fi
/bin/rm -f $(root)$(bindir)/stk $(root)$(bindir)/stk-$(VERSION)
ln -s $(execdir)/stk $(root)$(bindir)/stk-$(VERSION)
- ln -s $(execdir)/stk $(root)$(bindir)/stk
+ ln -s stk-$(VERSION) $(root)$(bindir)/stk
-if [ ! -d $(root)$(execdir) ] ; then mkdir -p $(root)$(execdir); fi
$(CP) stk $(root)$(execdir)
chmod 0755 $(root)$(execdir)/stk
@@ -127,7 +127,7 @@ install.snow: snow
-if [ ! -d $(root)$(bindir) ] ; then mkdir -p $(root)$(bindir); fi
/bin/rm -f $(root)$(bindir)/snow-$(VERSION) $(root)$(bindir)/snow
ln -s $(execdir)/snow $(root)$(bindir)/snow-$(VERSION)
- ln -s $(execdir)/snow $(root)$(bindir)/snow
+ ln -s snow-$(VERSION) $(root)$(bindir)/snow
-if [ ! -d $(root)$(execdir) ] ; then mkdir -p $(root)$(execdir); fi
$(CP) snow $(root)$(execdir)
chmod 0755 $(root)$(execdir)/snow