pkgsrc/net/torrentutils/patches/patch-aa
wiz 84cb4ee1c5 Fix installation to make less warnings, and make defrag use
bash, since it uses lots of bash features. Addresses PR 26799
by Simon Hitzemann.
Bump PKGREVISION for bash dependency.
2004-08-29 19:46:45 +00:00

44 lines
1.5 KiB
Text

$NetBSD: patch-aa,v 1.2 2004/08/29 19:46:45 wiz Exp $
--- Makefile.orig 2003-10-12 14:13:16.000000000 +0200
+++ Makefile
@@ -1,9 +1,9 @@
# Root of installation tree
-PREFIX = /home/usel/tmp
+#PREFIX = /home/usel/tmp
# Path where the executables are installed
BINDIR = $(PREFIX)/bin
# Path where the manual pages are installed
-MANDIR = $(PREFIX)/share/man
+MANDIR = $(PREFIX)/man
# Path to Midnight Commander extfs
MCEXTFSDIR = $(PREFIX)/share/mc/extfs
@@ -41,22 +41,13 @@ torrentutils.spec: torrentutils.spec.in
cat $^ | sed "s,@VERSION@,$(VERSION),; \
s,@PACKAGE@,$(PACKAGE),; \
s,@AUTHORS@,$(AUTHORS)," > $@
- if [[ "$@" != *.spec ]]; then chmod a+x $@; fi
+ if [ "$@" != *.spec ]; then chmod a+x $@; fi
install: all
- install -d $(BINDIR) $(MANDIR)/man1
- install -m 755 torrenttool $(BINDIR)/torrenttool
- install -m 755 defrag $(BINDIR)
- rm -f tmp.torrenttool.$$
- install -m 644 torrenttool.1 $(MANDIR)/man1
- install -m 644 defrag.1 $(MANDIR)/man1
- install -d $(MCEXTFSDIR)
- install -m 755 torrentmcfs $(MCEXTFSDIR); \
- if [ -f $(MCEXTFSDIR)/extfs.ini ]; then \
- grep '^torrentmcfs$$' $(MCEXTFSDIR)/extfs.ini || echo 'torrentmcfs' >> $(MCEXTFSDIR)/extfs.ini; \
- else \
- echo "$(MCEXTFSDIR) does not exist. Not installing MC extfs support."; \
- fi
+ ${BSD_INSTALL_SCRIPT} torrenttool $(BINDIR)/torrenttool
+ ${BSD_INSTALL_SCRIPT} defrag $(BINDIR)
+ ${BSD_INSTALL_MAN} torrenttool.1 $(MANDIR)/man1
+ ${BSD_INSTALL_MAN} defrag.1 $(MANDIR)/man1
clean:
rm -f torrenttool torrentmcfs defrag torrentutils.spec