4f0def7336
Closes pr 5734 by Dan McMahill.
34 lines
1.1 KiB
Text
34 lines
1.1 KiB
Text
--- sources/Makefile.orig Mon Nov 15 16:47:49 1993
|
|
+++ sources/Makefile Fri Jul 10 11:16:20 1998
|
|
@@ -35,5 +35,5 @@
|
|
# Installation sites (GNU conventions):
|
|
#
|
|
-prefix = /usr/local
|
|
+prefix = ${PREFIX}
|
|
bindir = $(prefix)/bin
|
|
includedir = $(prefix)/include
|
|
@@ -48,5 +48,5 @@
|
|
CFLAGS = -O2 -Wall -ansi -fstrength-reduce -finline-functions
|
|
|
|
-LFLAGS = # only sometimes needed; see below for examples
|
|
+LFLAGS = -L${X11BASE}/lib # only sometimes needed; see below for examples
|
|
CPPFLAGS = -I. # only sometimes needed; see below for examples
|
|
BINDCMD = # only needed for EMX and DJGPP DOS extenders
|
|
@@ -280,14 +280,10 @@
|
|
|
|
install-bin: $(PROGRAM)
|
|
- -$(STRIP) $(PROGRAM)
|
|
- $(CP) $(PROGRAM) $(bindir)
|
|
- $(CHMOD) 755 $(bindir)/$(PROGRAM)
|
|
+ ${BSD_INSTALL_PROGRAM} $(PROGRAM) $(bindir)
|
|
|
|
install-info: hp2xx.info
|
|
- $(CP) hp2xx.info $(infodir)
|
|
- $(CHMOD) 644 $(infodir)/hp2xx.info
|
|
+ ${BSD_INSTALL_MAN} hp2xx.info $(infodir)
|
|
|
|
install-man: ../doc/hp2xx.1
|
|
- $(CP) ../doc/hp2xx.1 $(man1dir)
|
|
- $(CHMOD) 644 $(man1dir)/hp2xx.1
|
|
+ ${BSD_INSTALL_MAN} ../doc/hp2xx.1 $(man1dir)
|
|
|