From hiramatu /at/ boreas _dot_ dti _dot_ ne _dot_ jp in PR#29890, with a few modifications by me. * ver 4.51 (Jan.16th,2004) + fixed keyboard-interrupt handling while reloading a file to avoid segmentation fault. (pointed out by Masanori GOTO <gotom@debian.or.jp>) + modified definitions of boolean_t, PAGE_SIZE, VDISCARD, and autoconf for libcurses for AIX. (pointed out by SHIOTA Shoichi <Shoichi.Shiota@lightwell.co.jp>) + omitted to specify owner and group to install command, and omitted include langinfo.h when HAVE_LANGINFO_CODESET is not defined, for Max OS X. (pointed out by Koki NAKASHIRO <nakasiro@sdl.hitachi.co.jp>)
27 lines
851 B
Text
27 lines
851 B
Text
$NetBSD: patch-aa,v 1.4 2005/04/05 14:56:06 cube Exp $
|
|
|
|
--- ../src/Makefile.in.orig 2004-01-06 08:22:17.000000000 +0100
|
|
+++ ../src/Makefile.in
|
|
@@ -64,18 +64,10 @@ depend::
|
|
#
|
|
|
|
install::
|
|
- $(INSTALL) -s -m 555 lv $(bindir)
|
|
- if test -f $(bindir)/lgrep; then \
|
|
- /bin/rm -f $(bindir)/lgrep; \
|
|
- fi
|
|
- (cd $(bindir); ln lv lgrep)
|
|
- if test ! -d $(lvlibdir); then \
|
|
- mkdir -p $(lvlibdir); \
|
|
- fi
|
|
- $(INSTALL) -m 444 $(srcdir)/../lv.hlp $(lvlibdir)
|
|
- if test -d $(mandir) -a -d $(mandir)/man1; then \
|
|
- $(INSTALL) -m 444 $(srcdir)/../lv.1 $(mandir)/man1; \
|
|
- fi
|
|
+ $(BSD_INSTALL_PROGRAM) lv $(bindir)/lv
|
|
+ $(LN) -s lv $(bindir)/lgrep
|
|
+ $(BSD_INSTALL_DATA) $(srcdir)/../lv.hlp $(lvlibdir)/lv.hlp
|
|
+ $(BSD_INSTALL_MAN) $(srcdir)/../lv.1 $(mandir)/man1; \
|
|
|
|
uninstall::
|
|
for i in $(bindir)/lv $(bindir)/lgrep $(lvlibdir)/lv.hlp $(mandir)/man1/lv.1; do \
|