Notable changes in version 9.4.3: The system-specific Icon configurations have been reorganized and renamed. The several BSD configurations have been merged into one. The macintosh configuration now supports the loadfunc function. A new porting guide has been written, and a new posix configuration has been added as a starting point in constructing new ports. The core library files remain stable. Notable changes include: - procs/dijkstra new procedures implement Dijkstra's control structures - procs/html add procedure for canonicalization of paths - procs/matrix2 new procedures for matrix manipulation - procs/nestlist new procedures for representing nested lists as strings - procs/printf add %e format and fix a rounding problem - progs/noise new program for producing a random bitstream - progs/unclog improve logic for combining adjacent entries - gprogs/dlgvu improve coverage map; allow altitude in GPS data - gprogs/gallery faster thumbnail loading for JPEG images - gprogs/img many new features - gprogs/sier better color choices - gprogs/trkvu accept GPS track logs with altitude as the last field The undocumented save function, which only worked on a few platforms, has been removed. Approved by <tnn>.
37 lines
1 KiB
Text
37 lines
1 KiB
Text
$NetBSD: patch-aw,v 1.6 2009/02/08 12:51:05 asau Exp $
|
|
|
|
--- src/common/Makefile.orig 2003-07-05 21:30:35.000000000 +0400
|
|
+++ src/common/Makefile 2009-02-08 01:41:40.000000000 +0300
|
|
@@ -5,7 +5,7 @@
|
|
munix.o literals.o rswitch.o alloc.o long.o getopt.o time.o\
|
|
xwindow.o dlrgint.o ipp.o
|
|
|
|
-common: doincl $(OBJS) gpxmaybe
|
|
+common: doincl patchstr $(OBJS) fixheaders gpxmaybe
|
|
|
|
doincl: doincl.c ../h/arch.h
|
|
$(CC) $(CFLAGS) -o doincl doincl.c
|
|
@@ -13,13 +13,22 @@
|
|
|
|
patchstr: patchstr.c
|
|
$(CC) $(CFLAGS) -o patchstr patchstr.c
|
|
+ cp patchstr ../../bin
|
|
+
|
|
+fixheaders:
|
|
+ cd ../h; for f in *.h; do \
|
|
+ sed -e 's:../h/::g;s:../xpm/::g' $$f > ../../lib/icon/$$f; \
|
|
+ done
|
|
|
|
gpxmaybe:
|
|
-if [ "x$(XL)" != "x" ]; then $(MAKE) $(GDIR); fi
|
|
|
|
xpm:
|
|
cd ../xpm; $(MAKE) libXpm.a
|
|
- cp -p ../xpm/libXpm.a ../../bin/libIgpx.a
|
|
+ cp -p ../xpm/libXpm.a ../../lib/icon/libIgpx.a
|
|
+ cd ../xpm; for f in *.h; do \
|
|
+ sed -e 's:../h/::g;s:../xpm/::g' $$f > ../../lib/icon/$$f; \
|
|
+ done
|
|
|
|
wincap:
|
|
cd ../wincap; $(MAKE) libWincap.a
|