pkgsrc/net/xymon/patches/patch-build_Makefile.SunOS
spz 544cf480ee update xymon + xymonclient to 4.3.28
notable changes: OpenSSL 1.1.0 is now supported, and c-ares has been updated

While touching the package anyhow, it has been taught to pass down hardening
flags, so that the various PKGSRC_USE_ flags now have effect.
2017-09-28 10:40:35 +00:00

18 lines
721 B
Text

$NetBSD: patch-build_Makefile.SunOS,v 1.1 2017/09/28 10:40:35 spz Exp $
make sure hardening flags can be inherited
--- build/Makefile.SunOS.orig 2012-08-01 08:48:15.000000000 +0000
+++ build/Makefile.SunOS
@@ -9,9 +9,9 @@ NETLIBS = -lresolv -lsocket -lnsl
CC = gcc
GCCVER := $(shell gcc -dumpversion|cut -d. -f1)
ifeq ($(GCCVER),4)
- CFLAGS = -g -O2 -Wall -Wno-unused -Wno-pointer-sign -D_REENTRANT $(LFSDEF) $(OSDEF)
+ CFLAGS += -g -O2 -Wall -Wno-unused -Wno-pointer-sign -D_REENTRANT $(LFSDEF) $(OSDEF)
else
- CFLAGS = -g -O2 -Wall -Wno-unused -D_REENTRANT $(LFSDEF) $(OSDEF)
+ CFLAGS += -g -O2 -Wall -Wno-unused -D_REENTRANT $(LFSDEF) $(OSDEF)
endif
# This guesswork doesnt work on a lot of systems.