140 lines
4.6 KiB
Text
140 lines
4.6 KiB
Text
$NetBSD: patch-ab,v 1.6 2002/10/25 12:18:16 wiz Exp $
|
|
|
|
--- Local/Makefile.netbsd.orig Fri Oct 25 14:04:25 2002
|
|
+++ Local/Makefile.netbsd
|
|
@@ -98,7 +98,9 @@
|
|
# /usr/local/sbin. The installation script will try to create this directory,
|
|
# and any superior directories, if they do not exist.
|
|
|
|
-BIN_DIRECTORY=/usr/exim/bin
|
|
+HAVE_IPV6=YES
|
|
+
|
|
+BIN_DIRECTORY=@PREFIX@/sbin
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -113,7 +115,7 @@ BIN_DIRECTORY=/usr/exim/bin
|
|
# directories if they don't exist. It will also install a default run time
|
|
# configuration if this file does not exist.
|
|
|
|
-CONFIGURE_FILE=/usr/exim/configure
|
|
+CONFIGURE_FILE=@PREFIX@/etc/exim/configure
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -126,7 +128,7 @@ CONFIGURE_FILE=/usr/exim/configure
|
|
# owner of a local mailbox.) Specifying these values as root is very strongly
|
|
# discouraged. These values are compiled into the binary.
|
|
|
|
-EXIM_USER=
|
|
+EXIM_USER=mail
|
|
|
|
# If the setting of EXIM_USER is numeric (e.g. EXIM_USER=42), there must
|
|
# also be a setting of EXIM_GROUP. If, on the other hand, you use a name
|
|
@@ -207,7 +209,7 @@ TRANSPORT_SMTP=yes
|
|
# This one is special-purpose, and commonly not required, so it is not
|
|
# included by default.
|
|
|
|
-# TRANSPORT_LMTP=yes
|
|
+TRANSPORT_LMTP=yes
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -216,9 +218,9 @@ TRANSPORT_SMTP=yes
|
|
# MBX, is included only when requested. If you do not know what this is about,
|
|
# leave these settings commented out.
|
|
|
|
-# SUPPORT_MAILDIR=yes
|
|
-# SUPPORT_MAILSTORE=yes
|
|
-# SUPPORT_MBX=yes
|
|
+SUPPORT_MAILDIR=yes
|
|
+SUPPORT_MAILSTORE=yes
|
|
+SUPPORT_MBX=yes
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -281,7 +283,7 @@ LOOKUP_LSEARCH=yes
|
|
# files are defaulted in the OS/Makefile-Default file, but can be overridden in
|
|
# local OS-specific make files.
|
|
|
|
-EXIM_MONITOR=eximon.bin
|
|
+# EXIM_MONITOR=eximon.bin
|
|
|
|
|
|
|
|
@@ -302,9 +304,9 @@ EXIM_MONITOR=eximon.bin
|
|
# included in the Exim binary. You will then need to set up the run time
|
|
# configuration to make use of the mechanism(s) selected.
|
|
|
|
-# AUTH_CRAM_MD5=yes
|
|
-# AUTH_PLAINTEXT=yes
|
|
-# AUTH_SPA=yes
|
|
+AUTH_CRAM_MD5=yes
|
|
+AUTH_PLAINTEXT=yes
|
|
+AUTH_SPA=yes
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -315,8 +317,8 @@ EXIM_MONITOR=eximon.bin
|
|
# with TLS support. If you don't know what this is all about, leave these
|
|
# settings commented out.
|
|
|
|
-# SUPPORT_TLS=yes
|
|
-# TLS_LIBS=-lssl -lcrypto
|
|
+SUPPORT_TLS=yes
|
|
+TLS_LIBS=-L${SSLBASE}/lib -Wl,-R${SSLBASE}/lib -lssl -lcrypto
|
|
|
|
# If you are running Exim as a server, note that just building it with TLS
|
|
# support is not all you need to do. You also need to set up a suitable
|
|
@@ -371,7 +373,7 @@ EXIM_MONITOR=eximon.bin
|
|
# %s. This will be replaced by one of the strings "main", "panic", or "reject"
|
|
# to form the final file names. Some installations may want something like this:
|
|
|
|
-# LOG_FILE_PATH=/var/log/exim_%slog
|
|
+LOG_FILE_PATH=/var/log/exim/%slog
|
|
|
|
# which results in files with names /var/log/exim_mainlog, etc. The directory
|
|
# in which the log files are placed must exist; Exim does not try to create
|
|
@@ -467,14 +469,14 @@ ZCAT_COMMAND=/usr/bin/zcat
|
|
# this setting. See the manual section entitled "Use of tcpwrappers" in the
|
|
# chapter on building and installing Exim.
|
|
|
|
-# USE_TCP_WRAPPERS=yes
|
|
+USE_TCP_WRAPPERS=yes
|
|
|
|
# You may well also have to specify a local "include" file and an additional
|
|
# library for TCP wrappers, so you probably need something like this:
|
|
|
|
# USE_TCP_WRAPPERS=yes
|
|
# CFLAGS=-O -I/usr/local/include
|
|
-# EXTRALIBS_EXIM=-L/usr/local/lib -lwrap
|
|
+EXTRALIBS_EXIM=-lwrap
|
|
|
|
# but of course there may need to be other things in CFLAGS and EXTRALIBS_EXIM
|
|
# as well.
|
|
@@ -511,11 +513,11 @@ ZCAT_COMMAND=/usr/bin/zcat
|
|
# haven't got Perl, Exim will still build and run; you just won't be able to
|
|
# use those utilities.
|
|
|
|
-# CHOWN_COMMAND=/usr/bin/chown
|
|
-# CHGRP_COMMAND=/usr/bin/chgrp
|
|
-# MV_COMMAND=/bin/mv
|
|
-# RM_COMMAND=/bin/rm
|
|
-# PERL_COMMAND=/usr/bin/perl
|
|
+CHOWN_COMMAND=/usr/sbin/chown
|
|
+CHGRP_COMMAND=/usr/bin/chgrp
|
|
+MV_COMMAND=/bin/mv
|
|
+RM_COMMAND=/bin/rm
|
|
+PERL_COMMAND=@PREFIX@/bin/perl
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -695,7 +697,7 @@ ZCAT_COMMAND=/usr/bin/zcat
|
|
# (process id) to a file so that it can easily be identified. The path of the
|
|
# file can be specified here. Some installations may want something like this:
|
|
|
|
-# PID_FILE_PATH=/var/lock/exim.pid
|
|
+PID_FILE_PATH=/var/run/exim.pid
|
|
|
|
# If PID_FILE_PATH is not defined, Exim writes a file in its spool directory
|
|
# using the name "exim-daemon.pid".
|