pkgsrc/math/qalculate-gtk/patches/patch-ac
drochner 85431ab5c8 update to 0.9.7
changes:
General build updates and bug fixes, including the ability to
 build against cln >= 1.2
2010-04-13 17:28:34 +00:00

76 lines
2.7 KiB
Text

$NetBSD: patch-ac,v 1.4 2010/04/13 17:28:34 drochner Exp $
--- configure.in.orig 2010-01-05 15:43:49.000000000 +0000
+++ configure.in
@@ -55,6 +55,35 @@ fi
changequote([,])dnl
+dnl -------------------------------------
+dnl | internationalization (i18n) support |------------------------------------
+dnl -------------------------------------
+
+GETTEXT_PACKAGE=qalculate-gtk
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The package name for gettext])
+
+dnl Please keep this in alphabetical order
+ALL_LINGUAS="nl sv"
+AM_GLIB_GNU_GETTEXT
+
+dnl AM_GLIB_GNU_GETTEXT sets $DATADIRNAME
+AC_MSG_CHECKING(locale directory)
+if test "x$prefix" = "xNONE"; then
+ PACKAGE_LOCALE_DIR=$ac_default_prefix/share/locale
+else
+ PACKAGE_LOCALE_DIR=$prefix/share/locale
+fi
+
+AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "$PACKAGE_LOCALE_DIR",
+ [The directory in which qalculate's locale data will be stored])
+ AC_MSG_RESULT("$PACKAGE_LOCALE_DIR")
+
+
+
+INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
+AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
+
dnl --------------------------------
dnl | check for neccessary libraries |-----------------------------------------
dnl --------------------------------
@@ -142,35 +171,6 @@ AC_SUBST(QALCULATE_GTK)
AC_SUBST(LN_QALCULATE)
-dnl -------------------------------------
-dnl | internationalization (i18n) support |------------------------------------
-dnl -------------------------------------
-
-GETTEXT_PACKAGE=qalculate-gtk
-AC_SUBST(GETTEXT_PACKAGE)
-AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The package name for gettext])
-
-dnl Please keep this in alphabetical order
-ALL_LINGUAS="nl sv"
-AM_GLIB_GNU_GETTEXT
-
-dnl AM_GLIB_GNU_GETTEXT sets $DATADIRNAME
-AC_MSG_CHECKING(locale directory)
-if test "x$prefix" = "xNONE"; then
- PACKAGE_LOCALE_DIR=$ac_default_prefix/share/locale
-else
- PACKAGE_LOCALE_DIR=$prefix/share/locale
-fi
-
-AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "$PACKAGE_LOCALE_DIR",
- [The directory in which qalculate's locale data will be stored])
- AC_MSG_RESULT("$PACKAGE_LOCALE_DIR")
-
-
-
-INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
-AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
-
dnl --------
dnl | output |-----------------------------------------------------------------
dnl --------