pkgsrc/lang/clisp/patches/patch-al
tron d60396b622 Use "$(TOOLS_PLATFORM.install)" instead of hard coded "install" to
fix build problems under Solaris. Based on a suggestion by Aleksey Cheusov.
2007-04-01 12:45:39 +00:00

13 lines
639 B
Text

$NetBSD: patch-al,v 1.2 2007/04/01 12:45:40 tron Exp $
--- ffcall/callback/trampoline_r/Makefile.in.orig 2006-04-28 11:10:31.000000000 +0300
+++ ffcall/callback/trampoline_r/Makefile.in
@@ -124,7 +124,7 @@ libtrampoline.la : $(OBJECTS)
# $(libdir) and $(includedir) - don't use $(prefix) and $(exec_prefix) here.
install-lib : all force
if [ ! -d $(includedir) ] ; then mkdir $(includedir) ; fi
- $(INSTALL_DATA) trampoline_r.h $(includedir)/trampoline_r.h
+ $(TOOLS_PLATFORM.install) -c -m 644 trampoline_r.h $(includedir)/trampoline_r.h
install : all force
if [ ! -d $(DESTDIR)$(prefix) ] ; then mkdir $(DESTDIR)$(prefix) ; fi