pkgsrc/chat/smirk/patches/patch-aa
bjs a20321c62e - Handle ncurses dependency properly, eliminating unintentional inclusion
of mk/curses.b3.mk after devel/ncurses/b3.mk.

 - Define DATADIR correctly so that it knows where to look for help files.

 - Remove quotes around DOCS_PATH in snprintf() call so that smirk can
   actually open the help files.

 - Bump PKGREVISION.
2008-06-30 22:23:34 +00:00

13 lines
379 B
Text

$NetBSD: patch-aa,v 1.1 2008/06/30 22:23:34 bjs Exp $
--- src/screen.c.orig 2007-05-08 10:18:18.000000000 -0400
+++ src/screen.c
@@ -2195,7 +2195,7 @@ int print_help_file(help *H, char *filen
char line[4096];
char path[4096];
- sprintf(path,"%s/%s/%s","DOCS_PATH","help",filename);
+ sprintf(path,"%s/%s/%s",DOCS_PATH,"help",filename);
fp = fopen(path, "rb");