* Bug fixes * New features: - otherlibs/labltk: browser uses menu bars instead of menu buttons Changes 3.09.0: Language features: - Introduction of private row types, for abstracting the row in object and variant types. Type checking: - Polymorphic variants with at most one constructor [< `A of t] are no longer systematically promoted to the exact type [`A of t]. This was more confusing than useful, and created problems with private row types. Native-code compiler (ocamlopt): * Revised implementation of the -pack option (packing of several compilation units into one). The .cmx files that are to be packed with "ocamlopt -pack -o P.cmx" must be compiled with "ocamlopt -for-pack P". In exchange for this additional constraint, ocamlopt -pack is now available on all platforms (no need for binutils). * Fixed wrong evaluation order for arguments to certain inlined functions. * Other (see 'Changes')
31 lines
1.3 KiB
Text
31 lines
1.3 KiB
Text
$NetBSD: patch-ax,v 1.3 2006/01/16 09:41:48 adam Exp $
|
|
|
|
--- otherlibs/bigarray/Makefile.orig 2005-10-19 13:56:24.000000000 +0200
|
|
+++ otherlibs/bigarray/Makefile
|
|
@@ -16,7 +16,7 @@
|
|
include ../../config/Makefile
|
|
|
|
CC=$(BYTECC)
|
|
-CFLAGS=-I../../byterun -O $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS)
|
|
+CFLAGS+=-I../../byterun $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS)
|
|
CAMLC=../../ocamlcomp.sh -I ../unix
|
|
CAMLOPT=../../ocamlcompopt.sh -I ../unix
|
|
MKLIB=../../boot/ocamlrun ../../tools/ocamlmklib
|
|
@@ -41,13 +41,13 @@ bigarray.cmxa: $(CAML_OBJS:.cmo=.cmx)
|
|
$(CAML_OBJS:.cmo=.cmx)
|
|
|
|
install:
|
|
- if test -f dllbigarray.so; then cp dllbigarray.so $(STUBLIBDIR)/dllbigarray.so; fi
|
|
- cp bigarray.cmi bigarray.mli libbigarray.a bigarray.cma $(LIBDIR)
|
|
+ if test -f dllbigarray.so; then ${BSD_INSTALL_DATA} dllbigarray.so $(STUBLIBDIR)/dllbigarray.so; fi
|
|
+ ${BSD_INSTALL_DATA} bigarray.cmi bigarray.mli libbigarray.a bigarray.cma $(LIBDIR)
|
|
cd $(LIBDIR); $(RANLIB) libbigarray.a
|
|
- cp bigarray.h $(LIBDIR)/caml/bigarray.h
|
|
+ ${BSD_INSTALL_DATA} bigarray.h $(LIBDIR)/caml/bigarray.h
|
|
|
|
installopt:
|
|
- cp bigarray.a $(CAML_OBJS:.cmo=.cmx) bigarray.cmxa $(LIBDIR)
|
|
+ ${BSD_INSTALL_DATA} bigarray.a $(CAML_OBJS:.cmo=.cmx) bigarray.cmxa $(LIBDIR)
|
|
cd $(LIBDIR); $(RANLIB) bigarray.a
|
|
|
|
partialclean:
|