129c62d7da
Changes: * FIX) qCgiRequestParseQueries() - quoted boundary patch. (by Hidai Kenichi) * NEW) qStrUnchar() - remove character from head and tail of the string. * NEW) qDecoderVersion() - get the version string of qDecoder library. * FIX) minor fixes related packaging.
70 lines
2.8 KiB
Text
70 lines
2.8 KiB
Text
$NetBSD: patch-ac,v 1.2 2008/11/27 21:15:36 minskim Exp $
|
|
|
|
--- examples/Makefile.in.orig 2008-11-25 22:13:35.000000000 +0900
|
|
+++ examples/Makefile.in
|
|
@@ -31,47 +31,47 @@ CC = @CC@
|
|
CFLAGS = @CFLAGS@
|
|
DEFS = @DEFS@
|
|
INCLUDE = -I. -I@includedir@
|
|
-LIB = @libdir@/libqDecoder.a
|
|
+LIB = @libdir@/libqDecoder.la
|
|
|
|
## Main
|
|
all: query.cgi cookie.cgi multivalue.cgi upload.cgi uploadfile.cgi download.cgi streamedit.cgi session.cgi config.cgi socket.cgi obstack.cgi
|
|
|
|
query.cgi: query.o
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o query.cgi query.o ${LIB}
|
|
+ ${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o query.cgi query.o ${LIB}
|
|
|
|
cookie.cgi: cookie.o
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o cookie.cgi cookie.o ${LIB}
|
|
+ ${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o cookie.cgi cookie.o ${LIB}
|
|
|
|
multivalue.cgi: multivalue.o
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o multivalue.cgi multivalue.o ${LIB}
|
|
+ ${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o multivalue.cgi multivalue.o ${LIB}
|
|
|
|
upload.cgi: upload.o
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o upload.cgi upload.o ${LIB}
|
|
+ ${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o upload.cgi upload.o ${LIB}
|
|
chmod 6755 upload.cgi
|
|
|
|
uploadfile.cgi: uploadfile.o
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o uploadfile.cgi uploadfile.o ${LIB}
|
|
+ ${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o uploadfile.cgi uploadfile.o ${LIB}
|
|
chmod 6755 uploadfile.cgi
|
|
mkdir -p -m 755 upload tmp
|
|
|
|
download.cgi: download.o
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o download.cgi download.o ${LIB}
|
|
+ ${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o download.cgi download.o ${LIB}
|
|
|
|
streamedit.cgi: streamedit.o
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o streamedit.cgi streamedit.o ${LIB}
|
|
+ ${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o streamedit.cgi streamedit.o ${LIB}
|
|
|
|
session.cgi: session.o
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o session.cgi session.o ${LIB}
|
|
+ ${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o session.cgi session.o ${LIB}
|
|
chmod 6755 session.cgi
|
|
|
|
config.cgi: config.o
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o config.cgi config.o ${LIB}
|
|
+ ${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o config.cgi config.o ${LIB}
|
|
|
|
socket.cgi: socket.o
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o socket.cgi socket.o ${LIB}
|
|
+ ${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o socket.cgi socket.o ${LIB}
|
|
|
|
obstack.cgi: obstack.o
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o obstack.cgi obstack.o ${LIB}
|
|
+ ${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -o obstack.cgi obstack.o ${LIB}
|
|
|
|
## Clear Module
|
|
clean:
|
|
@@ -80,4 +80,4 @@ clean:
|
|
|
|
## Compile Module
|
|
.c.o:
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -c -o $@ $<
|
|
+ ${LIBTOOL} --mode=compile ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -c -o $@ $<
|