9cd6a39c3e
Mozilla Firefox is a free, open-source and cross-platform web browser for Windows, Linux, MacOS X and many other operating systems. It is fast and easy to use, and offers many advantages over other web browsers, such as tabbed browsing and the ability to block pop-up windows. Firefox also offers excellent bookmark and history management, and it can be extended by developers using industry standards such as XML, CSS, JavaScript, C++, etc. Many extensions are available. This package tracks 38 ESR.
15 lines
704 B
Text
15 lines
704 B
Text
$NetBSD: patch-ao,v 1.1 2015/07/09 14:13:51 ryoon Exp $
|
|
|
|
--- toolkit/mozapps/installer/packager.mk.orig 2015-06-24 21:28:03.000000000 +0000
|
|
+++ toolkit/mozapps/installer/packager.mk
|
|
@@ -122,8 +122,8 @@ endif
|
|
(cd $(DESTDIR)$(installdir) && tar -xf -)
|
|
$(NSINSTALL) -D $(DESTDIR)$(bindir)
|
|
$(RM) -f $(DESTDIR)$(bindir)/$(MOZ_APP_NAME)
|
|
- ln -s $(installdir)/$(MOZ_APP_NAME) $(DESTDIR)$(bindir)
|
|
-ifdef INSTALL_SDK # Here comes the hard part
|
|
+ ln -s $(installdir)/$(MOZ_APP_NAME) $(DESTDIR)$(bindir)/$(MOZILLA_PKG_NAME)
|
|
+ifeq ($(MOZ_APP_NAME),xulrunner)
|
|
$(NSINSTALL) -D $(DESTDIR)$(includedir)
|
|
(cd $(DIST)/include && $(TAR) $(TAR_CREATE_FLAGS) - .) | \
|
|
(cd $(DESTDIR)$(includedir) && tar -xf -)
|