9cd6a39c3e
Mozilla Firefox is a free, open-source and cross-platform web browser for Windows, Linux, MacOS X and many other operating systems. It is fast and easy to use, and offers many advantages over other web browsers, such as tabbed browsing and the ability to block pop-up windows. Firefox also offers excellent bookmark and history management, and it can be extended by developers using industry standards such as XML, CSS, JavaScript, C++, etc. Many extensions are available. This package tracks 38 ESR.
12 lines
428 B
Text
12 lines
428 B
Text
$NetBSD: patch-memory_jemalloc_Makefile.in,v 1.1 2015/07/09 14:13:52 ryoon Exp $
|
|
|
|
--- memory/jemalloc/Makefile.in.orig 2014-03-15 05:19:31.000000000 +0000
|
|
+++ memory/jemalloc/Makefile.in
|
|
@@ -21,3 +21,7 @@ endif
|
|
ifdef GNU_CC
|
|
CFLAGS += -std=gnu99
|
|
endif
|
|
+
|
|
+# XXX startup crash workaround for gcc47 on amd64
|
|
+jemalloc.$(OBJ_SUFFIX): OS_CFLAGS := $(filter-out -O3 -Ofast,$(OS_CFLAGS))
|
|
+jemalloc.$(OBJ_SUFFIX): MOZ_OPTIMIZE_FLAGS=
|