pkgsrc/lang/yap/patches/patch-aj
asau e81a55a0e7 Update to YAP 6.3.3
Notable changes in YAP 6.3.3

- exo compilation, a way to store large DBs much more compactly
- a new way to do save/restore
- improvements on the SWI interface, including improved support
  of SWI packages. The core IO code has been updated to the latest SWI devel.
- interfaces Prolog->R (r..eal from Nicos and all) and YAP->Python
- PRiSM port
- PFL, a new language to write graphical models, by Tiago Gomes
- gobs of bug fixes.


Notable changes in YAP 6.3.2

- new tabling code that supports a global table and answer subsumption
- an interface to gecode
- a low-level interface to R
- a low-level interface to CUDD and also to c2d
- a PRISM interface

- the gprof interface works again, it has been rewritten to save the log as a file.
- the save/restore now can save a module only, and does not depend on memory tricks.
- there is a first (needs lots of work) Windows console (based on SWI code).

- Lots of bug fixes


Notable changes in YAP 6.3

- YAP now uses the SWI Input/Output routines.
  This includes the SWI streams handling code,
  and the SWI write routines.
- YAP also includes support to the pldoc and plunit libraries.
- New implementation of saved state routines allows saving modules.
- GECODE interface.
2013-06-12 20:28:41 +00:00

15 lines
671 B
Text

$NetBSD: patch-aj,v 1.4 2013/06/12 20:28:41 asau Exp $
Don't attempt to strip scripts, it doesn't work.
--- packages/http/Makefile.in.orig 2012-07-07 02:14:37.000000000 +0200
+++ packages/http/Makefile.in 2013-03-07 12:27:41.027386177 +0100
@@ -60,7 +60,7 @@
mkdir -p $(DESTDIR)$(EXDIR)/pwp
(cd $(srcdir)/examples && $(INSTALL_DATA) $(EXAMPLES) $(DESTDIR)$(EXDIR))
(cd $(srcdir)/examples/pwp && $(INSTALL_DATA) *.pwp *.pl $(DESTDIR)$(EXDIR)/pwp)
- (cd $(srcdir)/examples && $(INSTALL_PROGRAM) $(EXAMPLEEXE) $(DESTDIR)$(EXDIR))
+ (cd $(srcdir)/examples && $(INSTALL_SCRIPT) $(EXAMPLEEXE) $(DESTDIR)$(EXDIR))
uninstall::
(cd $(LIBDIR) && rm -f $(LIBPL))