1f7c44739e
version 1.8.18 2016-10-08 * Add mac2str() and str2mac() to print/parse MAC address * Change formatting, remove commented-out code in src/plugins/imb/imbapi.c * Export find_lan_channel() as global * Expose _ipmi_get_channel_info() * Extend buf2str to allow separator * Fix indentation of #define in src/plugins/imb/imbapi.c * Fix missing `goto out_free;` when ipmi_parse_hex() returns (-1) * Fix warning for buf2str argument * Various Bug fixes version 1.8.17 2016-05-01 * Add INSTALL and NEWS, mandated by autoconf * Added missing ipmi_sel_supermicro.h to template Makefile.am * Check rsp->data_len in ipmi_sel_get_info() * Various Bug fixes version 1.8.16 2015-11-22 * Add _ipmi_get_channel_access() and _ipmi_get_channel_info() * Add _ipmi_get_user_access() and _ipmi_set_user_access() * Add _ipmi_get_user_name() * Add _ipmi_set_channel_access() function * Add _ipmi_set_user_password() function * Add limits check in get_cmdline_macaddr() * Change expression in ipmi_pef_get_info() in order to silence Coverity * Change expression in ipmi_pef_list_policies() in order to silence Coverity * Code cleanup in ipmi_user_main() * Create ask_password() and re-use code * Delete dead code from ipmi_sunoem_echo() * Don't output pidfile before parsing command line arguments * Don't use tmp variable since it's not necessary in ipmi_user_test() * Various Bug fixes version 1.8.15 2014-11-24 * Various Bug fixes version 1.8.14 2014-05-05 * Various Bug fixes version 1.8.13 2013-09-09 * Various Bug fixes version 1.8.12 released 2012-08-09 * Added IPMB dual bridge support (no need for driver support) * Enable compiler warnings and resolve all compiler warning so that ipmitool compiles and links with no warning or error messages * add ipmishell line to configure * fail configure when no curses or readline is found * support sensor bridging in free interface * Document the ipmitool dcmi commands in the ipmitool man page * Document that some commands are blocked by OpenIPMI. * Document the -N and -R options * fix manpage misdocumentation on cipher suite privilige configuration * Add build support for Dell OEM commands * Add new Dell OEM commands and update man page * added hpm and fwum in man page * man page update for fwum and hpm commands * Added documentation for 'ime' operating mode, used to update Intel ME. * add new -Y option to prompt user to enter kgkey * Add DCMI module (Data Center Management Interface) * Various Bug fixes
13 lines
558 B
Text
13 lines
558 B
Text
$NetBSD: patch-ad,v 1.3 2017/12/22 21:45:23 markd Exp $
|
|
|
|
--- contrib/Makefile.in.orig 2016-10-08 08:11:34.000000000 +0000
|
|
+++ contrib/Makefile.in
|
|
@@ -90,7 +90,7 @@ am__make_running_with_option = \
|
|
test $$has_opt = yes
|
|
am__make_dryrun = (target_option=n; $(am__make_running_with_option))
|
|
am__make_keepgoing = (target_option=k; $(am__make_running_with_option))
|
|
-pkgdatadir = $(datadir)/@PACKAGE@
|
|
+pkgdatadir = $(datadir)/examples/@PACKAGE@
|
|
pkgincludedir = $(includedir)/@PACKAGE@
|
|
pkglibdir = $(libdir)/@PACKAGE@
|
|
pkglibexecdir = $(libexecdir)/@PACKAGE@
|