pkgsrc/mail/thunderbird/patches/patch-ldap_sdks_c-sdk_build.mk
ryoon d2e70b0ab3 Update to 15.0
* Update Mozilla Lightning to 1.7
* Update Enigmail to 1.4.4 (functionality is not tested yet; should
  be updated)
* Regen patches

Changelog:
    NEW Multi-Channel Chat: You now can enjoy real time conversation with your contacts, right from your favorite messaging application.
    NEW Do Not Track: This option has been implemented as an addition to Search the Web.
    NEW Ubuntu One is now supported in Filelink - the option to upload large attachments to online storage services.
    NEW New User Interface: Thunderbird is replicating the new look and feel of Mozilla Firefox in an effort to provide a similar user experience across all Mozilla software desktop or mobile and all platforms.
    FIXED Various fixes and performance improvements
    FIXED Various security fixes
MFSA 2012-72 Web console eval capable of executing chrome-privileged code
MFSA 2012-70 Location object security checks bypassed by chrome code
MFSA 2012-68 DOMParser loads linked resources in extensions when parsing text/html
MFSA 2012-67 Installer will launch incorrect executable following new installation
MFSA 2012-65 Out-of-bounds read in format-number in XSLT
MFSA 2012-64 Graphite 2 memory corruption
MFSA 2012-63 SVG buffer overflow and use-after-free issues
MFSA 2012-62 WebGL use-after-free and memory corruption
MFSA 2012-61 Memory corruption with bitmap format images with negative height
MFSA 2012-59 Location object can be shadowed using Object.defineProperty
MFSA 2012-58 Use-after-free issues found using Address Sanitizer
MFSA 2012-57 Miscellaneous memory safety hazards (rv:15.0/ rv:10.0.7)
2012-09-02 06:43:39 +00:00

39 lines
1.9 KiB
Makefile

$NetBSD: patch-ldap_sdks_c-sdk_build.mk,v 1.2 2012/09/02 06:43:40 ryoon Exp $
--- ldap/sdks/c-sdk/build.mk.orig 2012-08-25 00:31:56.000000000 +0000
+++ ldap/sdks/c-sdk/build.mk
@@ -488,21 +488,21 @@ LINK_LIB = $(RM) $@; $(AR) $(AR_F
LINK_LIB2 = $(RM) $@; $(AR) $@ $(OBJS2); $(RANLIB) $@
ifneq ($(LD),$(CC))
ifdef SONAMEFLAG_PREFIX
-LINK_DLL = $(LD) $(DSO_LDOPTS) $(LDRPATHFLAG_PREFIX)$(RPATHFLAG) $(ALDFLAGS) \
+LINK_DLL = $(LD) $(DSO_LDOPTS) $(LDRPATHFLAG_PREFIX)$(RPATHFLAG) $(ALDFLAGS) $(OS_LDFLAGS) \
$(DLL_LDFLAGS) $(DLL_EXPORT_FLAGS) \
-o $@ $(SONAMEFLAG_PREFIX)$(notdir $@) $(OBJS)
else # SONAMEFLAG_PREFIX
-LINK_DLL = $(LD) $(DSO_LDOPTS) $(LDRPATHFLAG_PREFIX)$(RPATHFLAG) $(ALDFLAGS) \
+LINK_DLL = $(LD) $(DSO_LDOPTS) $(LDRPATHFLAG_PREFIX)$(RPATHFLAG) $(ALDFLAGS) $(OS_LDFLAGS) \
$(DLL_LDFLAGS) $(DLL_EXPORT_FLAGS) \
-o $@ $(OBJS)
endif # SONAMEFLAG_PREFIX
else # $(CC) is used to link libs
ifdef SONAMEFLAG_PREFIX
-LINK_DLL = $(LD) $(DSO_LDOPTS) $(RPATHFLAG_PREFIX)$(RPATHFLAG) $(ALDFLAGS) \
+LINK_DLL = $(LD) $(DSO_LDOPTS) $(RPATHFLAG_PREFIX)$(RPATHFLAG) $(ALDFLAGS) $(OS_LDFLAGS) \
$(DLL_LDFLAGS) $(DLL_EXPORT_FLAGS) \
-o $@ $(SONAMEFLAG_PREFIX)$(notdir $@) $(OBJS)
else # SONAMEFLAG_PREFIX
-LINK_DLL = $(LD) $(DSO_LDOPTS) $(RPATHFLAG_PREFIX)$(RPATHFLAG) $(ALDFLAGS) \
+LINK_DLL = $(LD) $(DSO_LDOPTS) $(RPATHFLAG_PREFIX)$(RPATHFLAG) $(ALDFLAGS) $(OS_LDFLAGS) \
$(DLL_LDFLAGS) $(DLL_EXPORT_FLAGS) \
-o $@ $(OBJS)
endif # SONAMEFLAG_PREFIX
@@ -517,7 +517,7 @@ SO_FILES_TO_REMOVE=so_locations
endif
ifneq (,$(filter BeOS Darwin NetBSD,$(OS_ARCH)))
-LINK_DLL = $(MKSHLIB) $(OBJS)
+LINK_DLL = $(MKSHLIB) $(OBJS) $(OS_LDFLAGS)
endif
ifeq ($(OS_ARCH), HP-UX)