pkgsrc/net/ORBit/patches/patch-ad
obache df8954fcc6 Skip SUBDIRS in popt.
No need to build in subdir and failed in intl subdirectory, because
some @XXXX@ are not replaced, syntax error for recent gmake.
2010-10-02 13:19:11 +00:00

33 lines
1 KiB
Text

$NetBSD: patch-ad,v 1.10 2010/10/02 13:19:11 obache Exp $
--- popt/Makefile.in.orig 2002-06-06 11:34:39.000000000 +0000
+++ popt/Makefile.in
@@ -108,16 +108,16 @@ AUTOMAKE_OPTIONS = 1.4 foreign
EXTRA_DIST = CHANGES autogen.sh $(noinst_MANS) popt.spec testit.sh po/Makefile.in.in po/POTFILES.in po/popt.pot popt.ps po/cs.po po/ro.po po/uk.po po/zh_CN.GB2312.po po/gl.po po/sk.po po/wa.po
-SUBDIRS = intl po
+SUBDIRS =
INCLUDES = -I$(top_srcdir)
noinst_PROGRAMS = test1 test2
test1_SOURCES = test1.c
-test1_LDFLAGS = -all-static
+test1_LDFLAGS =
test1_LDADD = $(noinst_LTLIBRARIES)
test2_SOURCES = test2.c
-test2_LDFLAGS = -all-static
+test2_LDFLAGS =
test2_LDADD = $(noinst_LTLIBRARIES)
noinst_SCRIPTS = testit.sh
@@ -141,7 +141,7 @@ CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
libpopt_la_LDFLAGS =
-libpopt_la_LIBADD =
+libpopt_la_LIBADD = $(INTLLIBS)
libpopt_la_OBJECTS = popt.lo findme.lo poptparse.lo poptconfig.lo \
popthelp.lo
noinst_PROGRAMS = test1$(EXEEXT) test2$(EXEEXT)