acc0a12614
Add php80 package version 8.0.3 (PHP 8.0.3) with current PHP framework of pkgsrc. PHP is a widely-used open source general-purpose scripting language that is especially suited for web development and can be embedded into HTML. It is modular, and object-oriented. Much of its syntax is borrowed from C, Java and Perl with a couple of unique PHP-specific features thrown in. The language is designed to allow web developers to write dynamically generated pages quickly. PHP 8.0 comes with numerous improvements and new features such as * Union Types * Named Arguments * Match Expressions * Attributes * Constructor Property Promotion * Nullsafe Operator * Weak Maps * Just In Time Compilation * And much much more...
15 lines
694 B
JavaScript
15 lines
694 B
JavaScript
$NetBSD: patch-ext_phar_Makefile.frag,v 1.1 2021/03/07 13:41:36 taca Exp $
|
|
|
|
Set shbang for phar correctly.
|
|
|
|
--- ext/phar/Makefile.frag.orig 2015-06-23 17:33:33.000000000 +0000
|
|
+++ ext/phar/Makefile.frag
|
|
@@ -18,7 +18,7 @@ PHP_PHARCMD_EXECUTABLE = ` \
|
|
else \
|
|
$(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; \
|
|
fi;`
|
|
-PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
|
|
+PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
|
|
|
|
$(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc
|
|
-@test -d $(builddir)/phar || mkdir $(builddir)/phar
|