efcdb2c809
* docs: help screen & man page * docs: add missing full-html flag * headers: include-what-you-use fixes * other: free backup ranges * prepare_memory bug: initialization missing * licensing: use FreeBSD license (was GNUv3) * parse_leases: exit at read error * getdata: realloc instead of asserting * getdata: potential overflow due unit change * bug: use uint32_t for IP numbers * analyze: use more logical variable names * getdata: initialize memory * all: include-what-you-see fixes * analyze: debugging leftover removed * THANKS: add Ahmed AL Dakhil * maint: coding style fixes * output: change to full html behaviour * build-sys: autotools configure.ac update * docs: NEWS update * docs: remove version from manual page * licensing: set placeholder properly * bug: use uint32_t for IP numbers * build-sys: ignore gprof & gcov files * getdata: new xstrstr function for performance * other: fix two warnings * build-sys: update news for release v2.16
19 lines
459 B
C
19 lines
459 B
C
$NetBSD: patch-src_dhcpd-pools.h,v 1.1 2011/07/20 07:03:53 adam Exp $
|
|
|
|
Include <string.h> here.
|
|
|
|
--- src/dhcpd-pools.h.orig 2011-07-20 06:31:06.000000000 +0000
|
|
+++ src/dhcpd-pools.h
|
|
@@ -52,6 +52,12 @@ extern char *malloc();
|
|
#define EXIT_SUCCESS 0
|
|
#endif /* STDC_HEADERS */
|
|
|
|
+#ifdef HAVE_STRING_H
|
|
+#include <string.h>
|
|
+#else
|
|
+#include <strings.h>
|
|
+#endif
|
|
+
|
|
#ifndef HAVE_PROGRAM_INVOCATION_SHORT_NAME
|
|
# ifdef HAVE___PROGNAME
|
|
extern char *__progname;
|