pkgsrc/lang/gcc/patches/patch-ah
jschauma 54a8f198e5 use ${INSTALL_INFO} rather than install-info, so that we don't accidently
use an old or non-compatible version that may be in the base system.
This makes this package install flawlessly under Linux.
2003-05-24 19:26:24 +00:00

19 lines
731 B
Text

$NetBSD: patch-ah,v 1.5 2003/05/24 19:26:26 jschauma Exp $
--- texinfo/doc/Makefile.in.orig Sat May 24 14:56:48 2003
+++ texinfo/doc/Makefile.in Sat May 24 14:59:51 2003
@@ -182,12 +182,12 @@
uninstall-info:
$(PRE_UNINSTALL)
- @if $(SHELL) -c 'install-info --version | sed 1q | fgrep -s -v -i debian' >/dev/null 2>&1; then \
+ @if $(SHELL) -c '${INSTALL_INFO} --version | sed 1q | fgrep -s -v -i debian' >/dev/null 2>&1; then \
ii=yes; \
else ii=; fi; \
for file in $(INFO_DEPS); do \
test -z "$ii" \
- || install-info --info-dir=$(DESTDIR)$(infodir) --remove $$file; \
+ || ${INSTALL_INFO} --info-dir=$(DESTDIR)$(infodir) --remove $$file; \
done
@$(NORMAL_UNINSTALL)
for file in $(INFO_DEPS); do \