ff4e6fc28e
* Fix SIGHUP signal handling (again). * Fix deadlock if Miredo fails to start.
24 lines
1 KiB
Text
24 lines
1 KiB
Text
$NetBSD: patch-ah,v 1.2 2010/06/15 23:49:30 pettai Exp $
|
|
|
|
--- misc/Makefile.in.orig 2009-11-05 20:03:42.000000000 +0100
|
|
+++ misc/Makefile.in 2010-06-08 23:15:53.000000000 +0200
|
|
@@ -296,7 +296,7 @@
|
|
$(am__aclocal_m4_deps):
|
|
install-confSCRIPTS: $(conf_SCRIPTS)
|
|
@$(NORMAL_INSTALL)
|
|
- test -z "$(confdir)" || $(MKDIR_P) "$(DESTDIR)$(confdir)"
|
|
+ test -z "$(examplesdir)/../rc.d" || $(MKDIR_P) "$(DESTDIR)$(examplesdir)/../rc.d"
|
|
@list='$(conf_SCRIPTS)'; test -n "$(confdir)" || list=; \
|
|
for p in $$list; do \
|
|
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
@@ -315,8 +315,8 @@
|
|
while read type dir files; do \
|
|
if test "$$dir" = .; then dir=; else dir=/$$dir; fi; \
|
|
test -z "$$files" || { \
|
|
- echo " $(INSTALL_SCRIPT) $$files '$(DESTDIR)$(confdir)$$dir'"; \
|
|
- $(INSTALL_SCRIPT) $$files "$(DESTDIR)$(confdir)$$dir" || exit $$?; \
|
|
+ echo " $(INSTALL_SCRIPT) $$files '$(DESTDIR)$(examplesdir)/../rc.d/$$dir'"; \
|
|
+ $(INSTALL_SCRIPT) $$files "$(DESTDIR)$(examplesdir)/../rc.d/$$dir" || exit $$?; \
|
|
} \
|
|
; done
|
|
|