pkgsrc/graphics/xzgv/patches/patch-ab
jlam 0bf397a2b4 Use the buildlink config script wrappers and remove a lot of unnecessary
buildlink.mk files already pulled in by imlib/buildlink.mk.
2001-08-23 15:56:41 +00:00

47 lines
1.5 KiB
Text

$NetBSD: patch-ab,v 1.3 2001/08/23 15:56:41 jlam Exp $
--- src/Makefile.orig Tue Apr 10 08:37:01 2001
+++ src/Makefile
@@ -9,7 +9,7 @@
# This gets definitions for CC, CFLAGS, BINDIR etc.
include ../config.mk
-CFLAGS+=-DBACKEND_$(BACKEND) `gtk-config --cflags`
+CFLAGS+=-DBACKEND_$(BACKEND) `${GTK_CONFIG} --cflags`
# I could do this less horribly if I made it GNU-make-specific,
# but I decided not to. And here we are. :-(
@@ -18,19 +18,19 @@
# `--libs' case.
#
BACKEND_CFLAGS=`case "$(BACKEND)" in \
- IMLIB1) imlib-config --cflags-gdk ;; \
- GDK_PIXBUF) gdk-pixbuf-config --cflags ;; \
+ IMLIB1) ${IMLIB_CONFIG} --cflags-gdk ;; \
+ GDK_PIXBUF) ${GDK_PIXBUF_CONFIG} --cflags ;; \
esac`
BACKEND_LIBS=`case "$(BACKEND)" in \
- IMLIB1) imlib-config --libs-gdk ;; \
- GDK_PIXBUF) gdk-pixbuf-config --libs ;; \
+ IMLIB1) ${IMLIB_CONFIG} --libs-gdk ;; \
+ GDK_PIXBUF) ${GDK_PIXBUF_CONFIG} --libs ;; \
esac`
# `all' makes install-info too, as it's a bit weird to have something
# compile when you do `make install'. :-)
# (It would also be weird to have it made by the `doc' Makefile, IMHO.)
-all: xzgv install-info
+all: xzgv
OBJS= main.o \
filedetails.o gotodir.o updatetn.o confirm.o help.o \
@@ -43,7 +43,7 @@
backend.o
xzgv: $(OBJS)
- $(CC) $(CFLAGS) -o xzgv $(OBJS) $(BACKEND_LIBS) -ljpeg -lpng -ltiff -lz
+ $(CC) $(CPPFLAGS) $(CFLAGS) -o xzgv $(OBJS) $(BACKEND_LIBS) $(LDFLAGS) -ljpeg -lpng -ltiff -lz
backend.o:
$(CC) $(CFLAGS) $(BACKEND_CFLAGS) -c -o backend.o backend.c