bulk of the porting work. Tested on SmartOS 32-bit. 64-bit builds currently fail, they should hopefully be fixed soon.
15 lines
502 B
Text
15 lines
502 B
Text
$NetBSD: patch-ar,v 1.4 2013/06/15 09:31:05 jperkin Exp $
|
|
|
|
freetype rpath.
|
|
|
|
--- jdk/make/sun/font/Makefile.orig 2013-05-29 03:57:57.000000000 +0000
|
|
+++ jdk/make/sun/font/Makefile
|
|
@@ -134,7 +134,7 @@ else
|
|
ifeq ($(USING_SYSTEM_FT_LIB), false)
|
|
FREETYPE_LIB = $(LIB_LOCATION)/$(LIB_PREFIX)freetype.$(LIBRARY_SUFFIX).6
|
|
endif
|
|
- OTHER_LDLIBS += -L$(FREETYPE_LIB_PATH) -lfreetype
|
|
+ OTHER_LDLIBS += -L$(FREETYPE_LIB_PATH) -Wl,-R$(FREETYPE_LIB_PATH) -lfreetype
|
|
endif
|
|
|
|
library:: $(FREETYPE_LIB)
|