27ce463e2d
PuTTY is a client program for the SSH, Telnet and Rlogin network protocols. These protocols are all used to run a remote session on a computer, over a network. PuTTY implements the client end of that session: the end at which the session is displayed, rather than the end at which it runs.
22 lines
797 B
Text
22 lines
797 B
Text
$NetBSD: patch-aa,v 1.1.1.1 2009/09/07 18:01:43 ahoka Exp $
|
|
|
|
--- unix/Makefile.gtk.orig 2009-09-06 01:30:15.000000000 +0200
|
|
+++ unix/Makefile.gtk
|
|
@@ -115,7 +115,7 @@ GTK_CONFIG = sh -c 'pkg-config gtk+-2.0
|
|
|
|
unexport CFLAGS # work around a weird issue with krb5-config
|
|
|
|
-CFLAGS = -O2 -Wall -Werror -g -I.././ -I../charset/ -I../windows/ -I../unix/ \
|
|
+CFLAGS += -O2 -Wall -Werror -g -I.././ -I../charset/ -I../windows/ -I../unix/ \
|
|
-I../mac/ -I../macosx/ $(shell $(GTK_CONFIG) --cflags) -D _FILE_OFFSET_BITS=64
|
|
XLDFLAGS = $(LDFLAGS) $(shell $(GTK_CONFIG) --libs)
|
|
ULDFLAGS = $(LDFLAGS)
|
|
@@ -127,7 +127,7 @@ endif
|
|
INSTALL=install
|
|
INSTALL_PROGRAM=$(INSTALL)
|
|
INSTALL_DATA=$(INSTALL)
|
|
-prefix=/usr/local
|
|
+prefix=$(PREFIX)
|
|
exec_prefix=$(prefix)
|
|
bindir=$(exec_prefix)/bin
|
|
mandir=$(prefix)/man
|