a7a9fd46ca
- Fix uninitialized indicators in conversion_into_type and conversion_use_type specialisations - Fixed placeholder matching for PostgreSQL-style casts with ORM - Fixed memory leaking in use binding in case of bind/unbind sequence - Fixed sscanf formatter for MinGW/MSVC in backends - Fixed partial placeholder name matching for ORM cases - Added test for use of indicators with rowset<row> - Added test for get_affected_rows after bulk operations Add options for selecting MySQL/PostgreSQL/SQLite backends, defaulting to PostgreSQL.
18 lines
601 B
Text
18 lines
601 B
Text
$NetBSD: patch-CMakeLists.txt,v 1.2 2013/09/11 12:22:33 joerg Exp $
|
|
|
|
--- CMakeLists.txt.orig 2013-09-11 10:45:29.000000000 +0000
|
|
+++ CMakeLists.txt
|
|
@@ -70,11 +70,13 @@ include(SociDependencies)
|
|
# Installation
|
|
###############################################################################
|
|
|
|
+if(NOT DEFINED SOCI_LIBDIR)
|
|
if(APPLE OR CMAKE_SIZEOF_VOID_P EQUAL 4)
|
|
set(SOCI_LIBDIR "lib")
|
|
else()
|
|
set(SOCI_LIBDIR "lib64")
|
|
endif()
|
|
+endif()
|
|
|
|
set(BINDIR "bin" CACHE PATH "The directory to install binaries into.")
|
|
set(LIBDIR ${SOCI_LIBDIR} CACHE PATH "The directory to install libraries into.")
|