f1fb57c495
New: - Added a fast XOR line drawing function in Xlib driver - Added support for GL_ARB_texture_mirrored_repeat to savage driver (supported only on Savage4 hardware). Changes: - Mesa now packaged in three parts: Library, Demos and GLUT Bug fixes: - GLX_X_RENDERABLE token wasn't accepted by glXChooseFBConfig - Some files were present multiple times in the 6.3.2 tarballs - r200_vtxtmp_x86.S file was missing from 6.3.2 tarball (bug 4207) - glxgears_fbconfig demo didn't work (bug 4237) - fixed bug when bilinear sampling 2d textures with borders - glXCreatePbuffer() could segfault instead of returning 0 (bug 4235) - fixed undefined frexp and rand in X.org libGLcore.a (bug 4242) - fixed a few problems with proxy color tables (bug 4270) - fixed precision problem in Z clearing (bug 4395) - glBitmap, glDraw/CopyPixels mistakenly generated selection hits - fixed potential segfault caused by reading pixels outside of renderbuffer bounds - glGetTexLevelParameter didn't accept GL_TEXTURE_DEPTH_SIZE_ARB - fixed memory corruption bug involving software alpha buffers - glReadPixels clipped by window bounds was sometimes broken - glDraw/CopyPixels of stencil data ignored the stencil write mask - glReadPixels from a texture bound to a framebuffer object didn't work - glIsRender/FramebufferEXT weren't totally correct - fixed a number of point size attenuation/fade bugs - fixed glFogCoord bug 4729 - GLX encoding for transpose matrix functions was broken - fixed broken fragment program KIL and SWZ instructions - fragment programs that wrote result.depth.z didn't work Changes 6.4.1: Bug fixes: - redefining a vertex program string didn't take effect in TNL module - fixed occasional segfault upon vertex/fragment parsing error - vertex program LIT instruction didn't handle 0^0=1 correctly - fragment program fog option didn't work with glDrawPixels, glBitmap - USE_MGL_NAMESPACE didn't work for x86-64 - OSMesa demos were missing from previous release tarballs - fixed problem with float->ushort conversion in glClear (bug 4992) - popping of GL_EYE_PLANE texgen state was broken (bug 4996) - popping of GL_SPOT_DIRECTION light state was broken (bug 5005) - fixed occasional triangle color interpolation problem on VMS - work around invalid free() call (bug 5131) - fixed BSD X server compilation problem by including stdint.h
59 lines
2.1 KiB
Text
59 lines
2.1 KiB
Text
$NetBSD: patch-ad,v 1.8 2006/01/19 12:53:17 adam Exp $
|
|
|
|
--- src/mesa/Makefile.orig 2005-07-26 07:55:56.000000000 +0200
|
|
+++ src/mesa/Makefile
|
|
@@ -14,13 +14,13 @@ GL_TINY = 0$(MESA_MAJOR)0$(MESA_MINOR)0$
|
|
.SUFFIXES : .cpp
|
|
|
|
.c.o:
|
|
- $(CC) -c $(INCLUDE_DIRS) $(CFLAGS) $< -o $@
|
|
+ ${LIBTOOL} --mode=compile $(CC) -c $(INCLUDE_DIRS) $(CFLAGS) $< -o $@
|
|
|
|
.cpp.o:
|
|
- $(CXX) -c $(INCLUDE_DIRS) $(CXXFLAGS) $< -o $@
|
|
+ ${LIBTOOL} --mode=compile $(CXX) -c $(INCLUDE_DIRS) $(CXXFLAGS) $< -o $@
|
|
|
|
.S.o:
|
|
- $(CC) -c $(INCLUDE_DIRS) $(CFLAGS) $< -o $@
|
|
+ ${LIBTOOL} --mode=compile $(CC) -c $(INCLUDE_DIRS) $(CFLAGS) $< -o $@
|
|
|
|
|
|
# Figure out what to make here
|
|
@@ -150,25 +150,23 @@ subdirs:
|
|
|
|
# Make the GL library
|
|
$(LIB_DIR)/$(GL_LIB_NAME): $(STAND_ALONE_OBJECTS)
|
|
- @ $(TOP)/bin/mklib -o $(GL_LIB) -linker '$(CC)' \
|
|
- -major $(GL_MAJOR) -minor $(GL_MINOR) -patch $(GL_TINY) \
|
|
- -install $(LIB_DIR) \
|
|
- $(MKLIB_OPTIONS) $(GL_LIB_DEPS) $(STAND_ALONE_OBJECTS)
|
|
+ ${LIBTOOL} --mode=link ${CC} -o ${GL_LIB_NAME:.so=.la} \
|
|
+ ${STAND_ALONE_OBJECTS:.o=.lo} \
|
|
+ -rpath ${PREFIX}/lib -version-info ${GL_MAJOR}:${GL_MINOR} \
|
|
+ -L${X11BASE}/lib -Wl,-R${X11BASE}/lib ${GL_LIB_DEPS}
|
|
|
|
# Make the OSMesa library
|
|
$(LIB_DIR)/$(OSMESA_LIB_NAME): $(OSMESA_DRIVER_OBJECTS) $(OSMESA16_OBJECTS)
|
|
@ if [ "${DRIVER_DIRS}" = "osmesa" ] ; then \
|
|
- $(TOP)/bin/mklib -o $(OSMESA_LIB) -linker '$(CC)' \
|
|
- -major $(MESA_MAJOR) \
|
|
- -minor $(MESA_MINOR) -patch $(MESA_TINY) \
|
|
- -install $(LIB_DIR) $(MKLIB_OPTIONS) \
|
|
- $(OSMESA_LIB_DEPS) $(OSMESA16_OBJECTS) ; \
|
|
+ ${LIBTOOL} --mode=link ${CC} -o ${OSMESA_LIB_NAME:.so=.la} \
|
|
+ ${OSMESA16_OBJECTS:.o=.lo} -rpath ${PREFIX}/lib \
|
|
+ -version-info ${MESA_MAJOR}:${MESA_MINOR} \
|
|
+ ${OSMESA_LIB_DEPS:S|-lGL|libGL.la|} ; \
|
|
else \
|
|
- $(TOP)/bin/mklib -o $(OSMESA_LIB) -linker '$(CC)' \
|
|
- -major $(MESA_MAJOR) \
|
|
- -minor $(MESA_MINOR) -patch $(GL_TINY) \
|
|
- -install $(LIB_DIR) $(MKLIB_OPTIONS) \
|
|
- $(OSMESA_LIB_DEPS) $(OSMESA_DRIVER_OBJECTS) ; \
|
|
+ ${LIBTOOL} --mode=link ${CC} -o ${OSMESA_LIB_NAME:.so=.la} \
|
|
+ ${OSMESA_DRIVER_OBJECTS:.o=.lo} -rpath ${PREFIX}/lib \
|
|
+ -version-info ${MESA_MAJOR}:${MESA_MINOR} \
|
|
+ ${OSMESA_LIB_DEPS:S|-lGL|libGL.la|} ; \
|
|
fi
|
|
|
|
|