aa90e64631
Changes in 1.5.1 - Fixes for the Oracle Studio 12.2 Fortran compiler. - Fix SPARC and SPARCv9 atomics. Thanks to Nicola Stange for the initial patch. - Fix Libtool issues with the IBM XL compiler in 64-bit mode. - Restore the reset of the libevent progress counter to avoid over-sampling the event library. - Update memory barrier support. - Use memmove (instead of memcpy) when necessary (e.g., source and destination overlap). - Fixed ompi-top crash. - Fix to handle Autoconf --program-transforms properly and other m4/configury updates. Thanks to the GASNet project for the --program transforms fix. - Allow hostfiles to specify usernames on a per-host basis. - Update wrapper compiler scripts to search for perl during configure, per request from the BSD maintainers. - Minor man page fixes. - Added --with-libltdl option to allow building Open MPI with an external installation of libltdl. - Fixed various issues with -D_FORTIFY_SOURCE=2. - Various VT fixes and updates. Notable changes in 1.5 - Added "knem" support: direct process-to-process copying for shared memory message passing. See http://runtime.bordeaux.inria.fr/knem/ and the README file for more details. - Updated shared library versioning scheme and linking style of MPI applications. The MPI application ABI has been broken from the v1.3/v1.4 series. MPI applications compiled against any prior version of Open MPI will need to, at a minimum, re-link. See the README file for more details. - Added "fca" collective component, enabling MPI collective offload support for Voltaire switches. - Fixed MPI one-sided operations with large target displacements. Thanks to Brian Price and Jed Brown for reporting the issue. - Fixed MPI_GET_COUNT when used with large counts. Thanks to Jed Brown for reporting the issue. - Made the openib BTL safer if extremely low SRQ settings are used. - Fixed handling of the array_of_argv parameter in the Fortran binding of MPI_COMM_SPAWN_MULTIPLE (** also to appear: 1.4.3). - Fixed malloc(0) warnings in some collectives. - Fixed a problem with the Fortran binding for MPI_FILE_CREATE_ERRHANDLER. Thanks to Secretan Yves for identifying the issue (** also to appear: 1.4.3). - Updates to the LSF PLM to ensure that the path is correctly passed. Thanks to Teng Lin for the patch (** also to appear: 1.4.3). - Fixes for the F90 MPI_COMM_SET_ERRHANDLER and MPI_WIN_SET_ERRHANDLER bindings. Thanks to Paul Kapinos for pointing out the issue (** also to appear: 1.4.3). - Fixed extra_state parameter types in F90 prototypes for MPI_COMM_CREATE_KEYVAL, MPI_GREQUEST_START, MPI_REGISTER_DATAREP, MPI_TYPE_CREATE_KEYVAL, and MPI_WIN_CREATE_KEYVAL. - Fixes for Solaris oversubscription detection. - If the PML determines it can't reach a peer process, print a slightly more helpful message. Thanks to Nick Edmonds for the suggestion. - Make btl_openib_if_include/exclude function the same way btl_tcp_if_include/exclude works (i.e., supplying an _include list overrides supplying an _exclude list). - Apply more scalable reachability algorithm on platforms with more than 8 TCP interfaces. - Various assembly code updates for more modern platforms / compilers. - Relax restrictions on using certain kinds of MPI datatypes with one-sided operations. Users beware; not all MPI datatypes are valid for use with one-sided operations! - Improve behavior of MPI_COMM_SPAWN with regards to --bynode. - Various threading fixes in the openib BTL and other core pieces of Open MPI. - Various help file and man pages updates. - Various FreeBSD and NetBSD updates and fixes. Thanks to Kevin Buckley and Aleksej Saushev for their work. - Fix case where freeing communicators in MPI_FINALIZE could cause process failures. - Print warnings if shared memory state files are opened on what look like networked filesystems. - Update libevent to v1.4.13. - Allow propagating signals to processes that call fork(). - Fix bug where MPI_GATHER was sometimes incorrectly examining the datatype on non-root processes. Thanks to Michael Hofmann for investigating the issue. - Various Microsoft Windows fixes. - Various Catamount fixes. - Various checkpoint / restart fixes. - Xgrid support has been removed until it can be fixed (patches would be welcome). - Added simplistic "libompitrace" contrib package. Using the MPI profiling interface, it essentially prints out to stderr when select MPI functions are invoked. - Update bundled VampirTrace to v5.8.2. - Add pkg-config(1) configuration files for ompi, ompi-c, ompi-cxx, ompi-f77, ompi-f90. See the README for more details. - Removed the libopenmpi_malloc library (added in the v1.3 series) since it is no longer necessary - Add several notifier plugins (generally used when Open MPI detects system/network administrator-worthy problems); each have their own MCA parameters to govern their usage. See "ompi_info --param notifier <name>" for more details. - command to execute arbitrary commands (e.g., run a script). - file to send output to a file. - ftb to send output to the Fault Tolerant Backplane (see http://wiki.mcs.anl.gov/cifts/index.php/CIFTS) - hnp to send the output to mpirun. - smtp (requires libesmtp) to send an email.
46 lines
2.2 KiB
Text
46 lines
2.2 KiB
Text
$NetBSD: patch-aj,v 1.2 2010/12/16 21:00:54 asau Exp $
|
|
|
|
Install configuration files into example directory.
|
|
|
|
--- opal/etc/Makefile.in.orig 2010-03-31 05:34:56.000000000 +0400
|
|
+++ opal/etc/Makefile.in 2010-03-31 20:54:20.000000000 +0400
|
|
@@ -35,6 +35,7 @@
|
|
#
|
|
VPATH = @srcdir@
|
|
pkgdatadir = $(datadir)/@PACKAGE@
|
|
+exampledir = $(pkgdatadir)/examples
|
|
pkgincludedir = $(includedir)/@PACKAGE@
|
|
pkglibdir = $(libdir)/@PACKAGE@
|
|
pkglibexecdir = $(libexecdir)/@PACKAGE@
|
|
@@ -1240,24 +1241,24 @@
|
|
# details why the mkdir is in install-data-local.
|
|
|
|
install-data-local:
|
|
- $(mkdir_p) $(DESTDIR)$(sysconfdir)
|
|
+ $(mkdir_p) $(DESTDIR)$(exampledir)
|
|
@ p="$(opal_config_files)"; \
|
|
if test "$(opal_file_from_platform)" = "yes"; then \
|
|
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
- echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(sysconfdir)/openmpi-mca-params.conf"; \
|
|
- $(INSTALL_DATA) $$d$$p $(DESTDIR)$(sysconfdir)/openmpi-mca-params.conf; \
|
|
+ echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(exampledir)/openmpi-mca-params.conf"; \
|
|
+ $(INSTALL_DATA) $$d$$p $(DESTDIR)$(exampledir)/openmpi-mca-params.conf; \
|
|
else \
|
|
for file in $$p; do \
|
|
- if test -f $(DESTDIR)$(sysconfdir)/openmpi-mca-params.conf; then \
|
|
+ if test -f $(DESTDIR)$(exampledir)/openmpi-mca-params.conf; then \
|
|
echo "******************************* WARNING ************************************"; \
|
|
echo "*** Not installing new $$file over existing file in:"; \
|
|
- echo "*** $(DESTDIR)$(sysconfdir)/$$file"; \
|
|
+ echo "*** $(DESTDIR)$(exampledir)/$$file"; \
|
|
echo "******************************* WARNING ************************************"; \
|
|
else \
|
|
if test -f "$$file"; then d=; else d="$(srcdir)/"; fi; \
|
|
f="`echo $$file | sed -e 's|^.*/||'`"; \
|
|
- echo " $(INSTALL_DATA) $$d$$file $(DESTDIR)$(sysconfdir)/$$f"; \
|
|
- $(INSTALL_DATA) $$d$$file $(DESTDIR)$(sysconfdir)/$$f; \
|
|
+ echo " $(INSTALL_DATA) $$d$$file $(DESTDIR)$(exampledir)/$$f"; \
|
|
+ $(INSTALL_DATA) $$d$$file $(DESTDIR)$(exampledir)/$$f; \
|
|
fi; \
|
|
done \
|
|
fi;
|